trouble making clamav on Slackware64 14.1

I've downloaded the latest clamav 0.98.6. Everything appears to build OK except for clamav-milter. It doesn't make at all and going to the ../clamav-milter directory and running make by hand gives: "Nothing to be done for `all'." even though there are not .o files in the directory.

I've tried making by hand: make optparser.o output.o getopt.o misc.o whitelist.o connpool.o netcode.o clamfi.o clamav-milter.o

which works, but when I `make clamav-milter` I get the following error:
$ make clamav-milter
  CCLD     clamav-milter
/usr/lib64/gcc/x86_64-slackware-linux/4.8.2/../../../../lib64/crt1.o: In function `_start':
/glibc-tmp-6c24f933c85007fb11dd9dfc6718fc52/glibc-2.17/csu/../sysdeps/x86_64/start.S:119: undefined reference to `main'
collect2: error: ld returned 1 exit status
make: *** [clamav-milter] Error 1

Open in new window

This problem is not a function of the clamav version because I downloaded and tried to build clamav-0.98.1 from my Slackware 32bit 13.37.0 and got exactly the same error. clamav-milter does make  on the 32bit system has been running there for over a year.

based on the error messages, I am suspecting some problem with glibc, on the 64 bit distro, but not enough of a systems-guy to know exactly what.

Can someone point me in the right direction?
LVL 1
jmarkfoleyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
Hi,

Are you building just the milter? I think the errors are because the milter relies on some objects that are part of the clamav entire project.

In the current setup, you have a package for clamav and want to add the milter?
Or are/have you built and installed clamav and now want to add the milter?
Nothing to build suggests that during the configuration, clamav-milter was not enabled if you look at the Makefile it might not be set....

Clamav configure: to make sure clamav-milter component is enabled/included.
$ ./configure --enable-milter in addition to your own customized options I.e. CFLAGS, CC, LDFLAGS, etc.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jmarkfoleyAuthor Commented:
Yup! That did the trick. How did I figure that out last year and not this time? That switch isn't mentioned in either README or INSTALL. It is buried amongst other switches on line 98 of `./configure --help`.

Thanks a bunch. That was an obscure one
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.