Write acces to converted virtual machine disk ?

I'm running VMWare workstation 11 on a Windows 7 Pro host in a domain.

I've converted an old Windows XP machine to a VM (versin 6.0) with VMWare Converter 3.0.3 and upgraded it to WS11 afterwards, a procedure that worked flawless with another, similar machine (which failed after using the last converter release).

For some reasons I can't get the machine up with a regular boot (BOSD) and can't use safe mode because it needs to be reactivated first. From the VMWare logs I think I could fix the the problem, but I need to have write acces to C:\WINDOWS\SYSTEM32 on the VM, first.

I've tried to mount that VM offline a virtual disk. That works basically, but I couldn't change files there even when mounted as read/write ... when trying to delete or rename files, Explorer nags for admin credentials, but I can't figure out what credentials are right - admin credentials from the host machine fail as well as admin credentials of the physical source machine (given with domain as "host\user").

Any hint how to get acces to the VM's files ?
LVL 14
frankhelkAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zephyr ICTCloud ArchitectCommented:
Did you try with the Disk Mount Utility to mount the vmdk directly into your Windows machine (in your explorer interface to be precise)? -- Normally this utility should be part of VMware Workstation already.

The tool is to be used through command line if I remember correctly... This way the disk "should" be writable ...

If you get stuck, or it doesn't work, let us know.
frankhelkAuthor Commented:
I didn't find that tool in VMWare's path, but in Windows Explorer's context menu a command a command "Map Virtual Disk" seems to have been installed along with VMWare WS11 which does exact that: Mount the VM's HDD into into Windows.

I could do that, and I did uncheck "Read Only". I can access files in read mode, and I can even do write access in regular directories (I've just edited some text file and wrote it back).

The problem starts when I try to i.e. rename files in C:\Windows\ and below ... in that case a a popup informs me that I need admin privileges to do that. If I use the button with the shield to provide the credentials, almost every credentials I know (even the local admin accounts of either host or VM source) won't get accepted. The local admin of the host gets accepted, but afterwards Windows tells me that the drive of the VM's disk is not accessible (sounds like dismounted or disconnected). But it's still there, that problem's only around for C:\Windows and below ...
Zephyr ICTCloud ArchitectCommented:
Hmmm ... The only thing coming to mind is changing the owner, but since you'd want to later re-use the vmdk, after the changes, it will probably not be a good way to go ... Unless you just do it for one file? But even then, the possibility exists to change that you'll need to provide credentials.
SolarWinds® Network Configuration Manager (NCM)

SolarWinds® Network Configuration Manager brings structure and peace of mind to configuration management. Bulk config deployment, automatic backups, change detection, vulnerability assessments, and config change templates reduce the time needed for repetitive tasks.

Zephyr ICTCloud ArchitectCommented:
I just thought of something else, did you run the Mount from an elevated prompt? (right-click run as administrator) ... This might sometimes be necessary, like in this case, even if you are the local admin.
frankhelkAuthor Commented:
Sorry for the delay ... besides of other stress I'm currently trying to figure out how to run the mapper in elevated mode.

I'll report back when I'm thru with that.
Zephyr ICTCloud ArchitectCommented:
No problem, I'm dealing with a customer crisis at the moment also, so I will not be around much this week.
frankhelkAuthor Commented:
I've digged a bit deeper ... mounting a virtual machine's disk in Windows with VMWare WS11 is realized as shell extension with InProcServer, it uses vmdkShellExt64.dll (under Win7x64). I think it's not tha easy to run that elevated ...
Zephyr ICTCloud ArchitectCommented:
The mapper is run through cmd no? Isn't it enough to run the cmd with elevated permissions?
frankhelkAuthor Commented:
No ... the mapper seems no longer to be a command line tool. It's now a explorer shell extension hooked to the .vxdm extension. For those files you could right click in explorer and choose "Map virtual disk" in the context menu. That pops up a dialog where you can choose the drive letter and if you like to have read-only or read-write access.

I suspect that I could call it with rundll.exe (which might be called elevated), but then I have to figure out which parameters are needed and how to pass them ... I couldn't find anything about the parameters in the registry.
Zephyr ICTCloud ArchitectCommented:
Hmmm it seems it's been a while I've used the tool ... I have no way to test it at the moment, wish I could be of further assistance.... Wouldn't the tool I mentioned, which you can download be an option, instead of using the native way delivered with WS11?
frankhelkAuthor Commented:
I'd try that ... do you have the d/l location at hand ?
Zephyr ICTCloud ArchitectCommented:
The link in my first post takes you there ... If that isn't the tool you are using now ... I might be confused :)
frankhelkAuthor Commented:
Thanks ... I've d/l'd it and tried to install, but the installer refused to go thru.

It tells that it didn't modify anything and eventlog indicates a cryptic result code 1603.
Zephyr ICTCloud ArchitectCommented:
Hmmm .... There's probably an install log in the temp directory somewhere with more specific info, do try to right-click run as administrator, that sometimes helps ...
frankhelkAuthor Commented:
Sorry - needs maybe a bit more time ... stay tuned ...
Zephyr ICTCloud ArchitectCommented:
no worries
frankhelkAuthor Commented:
Hmmm ... tried again with run as admin ... failed again:
Screenshot snippetAnd I can't find any log ...
Zephyr ICTCloud ArchitectCommented:
Crap ... The log should be in either the user temp folder or c:\temp ... Usually it's in the user's temp folder ...
frankhelkAuthor Commented:
I've finally found the log ... since the machine requires to run installers as admin, the log went to

c:\users\<admin>\Adddata\local\temp\...
The message prior to beginning the installation rolling back reads
CustomAction InstallVstor2Driver returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 16:32:27: InstallFinalize. Return value 3.
Then MSI started the rollback.

Maybe it collides with my VMWare Workstation 11 installation (which allows mounting, too ?)
Zephyr ICTCloud ArchitectCommented:
Hmmm, might be the case yes ... That VMWare workstation 11 is installed.

The only other thing I found is this Microsoft article, maybe something in there can help...

Wish I could be more helpful though :)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
frankhelkAuthor Commented:
I'll have to investigate the initial problem (the password thing) further, I think ... anyhow I award you some poinks for pointing me to the tool and helping with the log. If I come to a solution, I'll add another comment here ...
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.