Exchange Server 2013 Shared Mailbox not working

I have a simple Dell Server running Windows Server 2012 with 2 Virtual servers.  One is the Domain Controller and the other is my Exchange server 2013.  My problem:
I use to have a Public Folder setup with Mail enabled called Sales.
I figured out that a Shared Mailbox was the better way to do it
I deleted the Public Folder Sales
I created a Shared Mailbox Sales
when I try to send email to Sales@mydomain.com it bounces back
before I created the Sales Shared Mailbox I setup another Shared Mailbox called Info
When I send email to Info@mydomain.com it works just fine.

I created the Sales shared mailbox the same way.  Any ideas as to why it is not working?  I have deleted and created the Sales shared mailbox many times thinking I was doing something wrong.  It still is not working.
cimctoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hassan afzalIT Commented:
Are you trying to send internal emails ? or from an externall account?
can we see the bounce back
0
cimctoAuthor Commented:
This is a email link for external people to send email to our server for our sales people.  I want all the sales people to have one inbox in their Outlook that they all can see and read emails from people requesting sales information from our company.
0
hassan afzalIT Commented:
have you enabled "allow external people to email " on the mailbox properties?
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

cimctoAuthor Commented:
where do I do that?  I mean I have lots of other email address on the same domain that is working just fine.  I did not do anything to the "Info" shared mailbox when I created it and it receives external email just fine
0
hassan afzalIT Commented:
double click the shared mailbox -> go to mailbox features -> scroll down to message delivery restrictions, check the settings there.
0
cimctoAuthor Commented:
It is set to:
Accept Message from:
  All Senders

Reject Message from:
  No Senders
0
hassan afzalIT Commented:
can we see the bounce back ?
0
cimctoAuthor Commented:
I would prefer to not post that information, can you tell me what you are looking for in that message and maybe I can give you just that information?
0
cimctoAuthor Commented:
I just figure it out...my outlook was holding onto the old Auto populate address and when I typed in Sales it populated the To address with the old Sales@mydomain.com exchange address.  So it was trying to send to that address and not the new Sales@mydomain.com address.  So in Outlook when I started typing Sales I clicked on the X and deleted the cache of that old address and manual typed out the full address again.  It worked.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cimctoAuthor Commented:
I figure it out on my own
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.