Ubuntu on Hyper-V server NIC card disabled post restart.

I have setup an Ubuntu VM on a 2012 hyper-v host, and unlike its Windows counter parts on the same host, it has a strange issue, where it will disable the NIC card or wired connection every time I restart the VM.  I have to Hyper-v console to it and flip the GUI switch to on again.  What gives?  How do I get it to stop doing this?  Note I have just updated all of its built in software via the auto updater.

Thanks for the help.
CnicNVAsked:
Who is Participating?
 
rindiCommented:
You probably need to enable the integration services in your VM. Edit the /etc/initramfs-tools/modules file and add the following at the bottom of it (provided those aren't already there):

hv_vmbus
hv_storvsc
hv_blkvsc
hv_netvsc

then run:

sudo update-initramfs –u

and after that reboot.

This also allows you to use better display resolutions than the default you get.
0
 
CnicNVAuthor Commented:
Thanks for the info.  I tried what you suggested and it didn't work for the network issue, but it did make the screen resolution better.  

What I ended up doing was two fold...

First:  I had to check the checkbox under the wired connection to "connect automatically"
Second:  Since I was there, I also checked "Available to all users"

This got the NIC to stay online and ping'able through the restart process.

Thanks anyway :-)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.