how to copy mail box rules from one nsf to another

I have Lotus Notes 8.5.3 clients. Box mailboxes in question are the 8.5std template.

User A has forty plus folders and rules.

User B needs the same folders and rules.

Found agent script that successfully copied folders.

Need to copy the rules.
How can this be done?
probetechAsked:
Who is Participating?
 
probetechAuthor Commented:
I found this link which may point me in the right direction.
https://stujordan.wordpress.com/2012/01/18/copying-domino-mail-rules-between-databases/

Open to other, possibly simpler, solutions thoughh
0
 
Sjef BosmanGroupware ConsultantCommented:
Did you try to copy them manually? Copy/Paste?
0
 
probetechAuthor Commented:
Yes, doesn't work
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
probetechAuthor Commented:
Button above works. but it will only remove the attribute off of one document at a time regardless if several are selected. copying works but is tedious one at a time. Need to select ONE rule, remove attribute with button, copy, then paste into other nsf.  Can probably use this as its only  forty rules and i've done 10 so far but would be nice if it would work if highlighted all and then did one copy/paste
0
 
Sjef BosmanGroupware ConsultantCommented:
I found the same document... :)

I think that, if you use the formula under #6, and you select multiple documents, your button should treat all documents. Simpler code would just be:

     Field $KeepPrivate:= ""

The reverse operation (those rules aren't private for no good reason):

     Field $KeepPrivate:= "1"
0
 
probetechAuthor Commented:
Tried both options(#6 and the simple code). But it will only copy one at a time for some reason.
Thanks though
0
 
Sjef BosmanGroupware ConsultantCommented:
Only "copy" ?? That formula code doesn't copy at all, it only sets a document to 'copyable'. Once changed, select all rules and try to copy them all.
0
 
Sjef BosmanGroupware ConsultantCommented:
Ah, can't you select all Rules? Did you try Ctrl-A?
0
 
probetechAuthor Commented:
The solution I found partially works though I still can only copy one rule at a time. awarded  sjef 250 for the effort and simplifying the code.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.