Blank blue screen when RDPing into Window Server 2003

Vmware VM of Windows Server 2003
When trying to open console in vmware.. I see Windows Server 2003 logo when booting up then screen goes black and stays black.

When trying to RDP into the machine, enter credentials, screen stays blue.
-Explorer.exe is not running.. when trying to run from task manager.. nothing happens
-Ive tried clean boot
-Ive tried entering a registry entry for ignoreregusererrors
-ive tried running sfc/scannow
-periodically was getting rpc server not available errors

Desktop will not come up
This is a production accounting server and an emergency

please help
nickmart7Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zalazarCommented:
Can you try the following:
Check all windows services via services.msc and sort on the column startup type. All services that are on Automatic should be running, can you please report back which are not.
Check the Windows System Eventlog for errors/warnings.
Try to boot into safe mode, when server boots press F8, to see if the problem is also with safe mode.
Did you also check the task manager to see if there are processes which are using a lot of CPU ?
0
nickmart7Author Commented:
The same issue occurs in safe mode
I do not know how to open services from the task manager.. Since that is the only program I can access from blank screen
I've tried connecting to services remotely from my machine but it errors out
0
zalazarCommented:
Can you try File |New Task (Run...), type: services.msc  and press OK
If the window does not open.
  On the Application tab of the Task Manager "Services" should be visible.
  When right clicking on "Services" select "Switch To"
0
The 7 Worst Nightmares of a Sysadmin

Fear not! To defend your business’ IT systems we’re going to shine a light on the seven most sinister terrors that haunt sysadmins. That way you can be sure there’s nothing in your stack waiting to go bump in the night.

zalazarCommented:
You might also try to run File |New Task (Run...), type: mmc.exe and press OK
If the Management Console loads, from the File menu you can select Add/Remove Snap-in... and then Add...
to add e.g. Services, Event Viewer and Device Manager.
0
nickmart7Author Commented:
Ugh
When I try to run services.msc it errors out with access denied
When I try to run mmc.exe it errors out with class not registered
And I made sure to open mtsc /v:server name  /console
0
andreasSystem AdminCommented:
can you run any exe? e.g. calc.exe from the taskmanager or does this also error out?
0
nickmart7Author Commented:
i can run calc.exe... i can open some programs/apps from desktop folder...
0
andreasSystem AdminCommented:
did the machine recently installed some widows updates? do you remember what happened last before the problem started to appear?
0
nickmart7Author Commented:
i was trying to free up space.. because c drive was down under 1 gig
i deleted folders ie7 updates and ie8 updates.. as they didnt seem critical
i emptied out the temp folder
i ran a registry cleaner... (but i have since undid what that did.. to try and rectify this)
0
nickmart7Author Commented:
then i rebooted... no updates have installed...
0
andreasSystem AdminCommented:
what kind of update folders? from ie8 and ie7 please specify exact folder location and name if possible.

temp folders should be no problem.

which cleaner did you use? some of them cause havoc in some cases. How did you undid what the cleaner had done?
0
nickmart7Author Commented:
i believe they were under C:\windows directory

i used jetclean... it has an option to undo the changes it makes
0
andreasSystem AdminCommented:
did the update folders were the compressed ones with the $ sign in the name?

Maybe the cleaner cleand a little bit too well and then as a result of the not properly functioning windows was not able to undo all changes?

Try also to scan for malware, for this its best too boot the machine from a boot cd with a recent anti virus scanner.
0
nickmart7Author Commented:
i am remote... i cannot physically scan it.. as that would require.. being physically at the VM Host server.. putting in the cd and then setting up the vm to read the physical cd drive as its own...

SIdebar... i do have backups of this VM on Appassure..
When i try to export the appassure backup to the vm host server.. i get an error..
Does anyone have experience with Appassure vm restores here?

Invalid Operation Exception
Cannot execute an export task :

Soap Exception: Required property device is missing from data object of type VirtualDeviceConfigSpec
while parsing serialized DataObject of type vim.vm.device.VirtualDeviceSpec at line 1, column 382

while parsing property "deviceChange" of static type ArrayOfVirtualDeviceConfigSpec

while parsing serialized DataObject of type vim.vm.ConfigSpec at line 1, column 291

while parsing call information for method ReconfigVM_Task at line 1, column 218

while parsing SOAP body at line 1, column 207

while parsing SOAP envelope at line 1, column 38

while parsing HTTP request for method reconfigure on object of type vim.VirtualMachine at line 1, column 0
0
nickmart7Author Commented:
kaspersky virus removal tool found no threats....
0
zalazarCommented:
Unfortunately I do not have experience with  Appassure.
Can you maybe post what the registry cleaner did cleanup ?
0
nickmart7Author Commented:
0
zalazarCommented:
I can see why you have problems now.
Please try to import the attached registry file, rename .txt to .reg.
Import it, either by opening a cmd.exe  and
regedit.exe /s Regvalues1.reg

Open in new window

or by opening a "regedit.exe" and select File |Import...
Good luck.
Regvalues1.txt
0
nickmart7Author Commented:
i have done as instructed... no change
0
nickmart7Author Commented:
i cannot restore the vm backup ... but i do have access to the backup of the contents of c drive from the last few days
is it possible to manually copy the registry from this back up if the registry is the problem?
0
andreasSystem AdminCommented:
you might try to copy over, BUT you need to make a snapshot of the vm first. when it goes wrong you can just reset the machine to the previous state.

If lucky it might work, if unlucky it may work but it may introduce other problems that might not be apparent instantly and came out later, e.g. non functioning updates, failing installations of software,...

Your best and most clean way out would be to get the backup restored. If necessary contact the support from appassure.

Does the server had any FSMO roles? Did you already transfer them to new servers? If you transfered them then THEN: after restoring te backup dont connect the server back online else it may cause havoc in your ENTIRE Active Directory, as then 2 machines might be online with FSMO roles that should there only be once.
Same applies to shapshot resets.

im not sure if those transfered fsmo roles can be removed on the restored server before it goes back online. MS recommends only to seize roles if its sure the server will not come back online.
So if you already transfered roles you might be out of luck and the server might not be recoverable without RE-setup.

furthermore you might first try to restore the deleted files and directories from the backup before you overwrite the registry.
maybe it was not just an IE update directory and some important files were inside.
0
zalazarCommented:
Too bad that this didn't help.
Overwriting the registry on a running system is not possible.
What you might try is the following.
You need a Windows 7 or 2008 R2 installation ISO file for this and hopefully you have one available.
In the past it was possible to download the Windows 7 ISO via the URL's specified in this link but these seems not be valid anymore.
http://answers.microsoft.com/en-us/windows/forum/windows_7-windows_install/i-do-not-have-windows-7-media-but-i-do-have-my/5ce13741-ac25-4969-ae82-2494726aac1c

First copy the registry files from the Appassure backup to the local disk of the server.
E.g. to directory C:\Temp\RegBackup
Copy the following files to that directory
C:\WINDOWS\system32\config\default
C:\WINDOWS\system32\config\software
C:\WINDOWS\system32\config\system
C:\Documents and Settings\Administrator\NTUSER.DAT

Then load the Windows 7 or 2008 R2 installation ISO and start the server from CD/DVD.
This will load the Windows PE environment.
When loaded you can press "Shift-F10" to access a command prompt.
Make sure the C-drive is the Windows 2003 C-drive via:
dir c:\ /a

Then backup the current registry via:
mkdir C:\Temp\RegCurrent
copy /v C:\WINDOWS\system32\config\default C:\Temp\RegCurrent
copy /v C:\WINDOWS\system32\config\software C:\Temp\RegCurrent
copy /v C:\WINDOWS\system32\config\system C:\Temp\RegCurrent
attrib -h "C:\Documents and Settings\Administrator\NTUSER.DAT"
copy /v "C:\Documents and Settings\Administrator\NTUSER.DAT" C:\Temp\RegCurrent

Open in new window


Copy the registry files from the backup to the correct location:
copy /v/y C:\Temp\RegBackup\default C:\WINDOWS\system32\config
copy /v/y C:\Temp\RegBackup\software C:\WINDOWS\system32\config
copy /v/y C:\Temp\RegBackup\system C:\WINDOWS\system32\config
copy /v/y "C:\Temp\RegBackup\NTUSER.DAT" "C:\Documents and Settings\Administrator"
attrib +h "C:\Documents and Settings\Administrator\NTUSER.DAT"

Open in new window


Reboot the server via:
wpeutil reboot
0
nickmart7Author Commented:
I was able to restore a backup of the VM... thanks anyway guys.. good tips nonetheless
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
zalazarCommented:
It's very good to hear that you managed to restore the backup.
This will probably be the last time you used a registry cleaner. I actually never use those as they always give trouble and the advantage in speed/diskspace is almost none.
I can understand that you want to close the question but you might consider differently because andreas and I still spend some time on your question.
All the best with the rebuilded server.
0
nickmart7Author Commented:
none of the other solutions given worked
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.