• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 30
  • Last Modified:

2012 R2 File Server Access

I recently upgraded a File Server to Windows 2012 R2 Datacenter.  Everything went well and worked fine for weeks.  

A couple of days ago I enabled de-duplication on the server.  Now, I have one XP Professional Client and three Sharp MFP machines that cannot access the file server, or any of the SMB shares on the server.

When we try to scan to a network folder we get a send error code 80-0000.

I know that others have seen this before, but I haven't found a resolution to this issue.  Any assistance would be greatly appreciated.

Thank you,

Greg
0
Greg Sartin
Asked:
Greg Sartin
  • 2
  • 2
2 Solutions
 
Cliff GaliherCommented:
Make sure the SMB1.0/CIFS feature is installed. Most MFPs nor XP can talk SMB2 or 3. I'm guessing it got removed around the same time dedup got turned on.
0
 
Greg SartinAuthor Commented:
I have confirmed that SMB 1.0/CIFS is installed.  

When browsing from the XP machine, I can see the file server, but none of the shares.  It's like network discovery is not enabled, but it is.  

I have set HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\LmCompatibilityLevel value to 0 so that the file server will send LM & NTLM responses.  

I have tried to get an error to present itself in the logs, but the XP client can't even see the shares to try and connect to them.
0
 
Cliff GaliherCommented:
Network discovery does not control shares. Inky machine and device visibility. Allowing LM is a huge security risk. Even with XP, which as old as it is, still supports NTLMv2. Dedup happens at the filesystem level, lower than the networking stack that presents SMB to connecting devices, so enabling it would not impact file sharing. Something else was changed.
0
 
Greg SartinAuthor Commented:
Cliff,  Thank you for chiming in.  I agree with everything that you have stated above.  Sometimes it just helps to have someone to bounce things off of.  I resolved my issue by uninstalling SMB 1.0.CIFS and then re-installing the feature.  Somehow the feature became corrupt.  I was able to identify this using the Best Practices Analyzer.  It said that SRV.sys was not running.  Even after running "sc config srv start=demand", BPA said the same thing.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now