RDP LAN connection failing utilizing Cisco Site-to-Site VPN

We have an IPsec Site to Site VPN connection between Cisco 2911 router, (Home Office) and Cisco 861 router, (Remote site).

1.      Users behind 861 router ARE able to access resources behind 2911. Site-to-site working great.

2.      Users behind 861 ARE able to establish RDP connection to Terminal Server IF they use Public/Wan IP address, as in: 172.164.x.x:3389.

3.      However, users behind 861 ARE NOT able to establish RDP connection to Terminal Server IF they use Terminal Server  LAN IP address, as in: 10.11.X.X:3389.  Receiving “Remote Desktop Can’t connect to the remote computer” ….  Error.

4.      Remote users utilizing established Cisco VPN Client connection, NOT behind  2911 or 861, ARE able to RDP to Terminal Server IF they use Server LAN IP address, as in 10.11.X.X:3389

Appears to be issue with RDP while utilizing Site-to-Site.  Any thoughts or suggestions would be greatly appreciated.

Thank you!
Chip
atsandersAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Make sure you have:

Internal IP x.y.z.w -> External IP (Home) -> Internet <- External IP (Office) <- Internal IP a.b.c.d

The two external IP addresses are different (must be) and then make sure the Internal Addresses are on different subnets. This is necessary.

You may need to make HOSTS entries for the other site at each machine (c:\windows\system32\drivers\etc\hosts
0
atsandersAuthor Commented:
Thanks for the quick response John. I'll double check Cisco configs tomorrow and let you know. I did try entries in HOSTS file.
Chip
0
AkinsdNetwork AdministratorCommented:
Can the S-2-S users ping the terminal server's local IP.
If not, what is the address pool for the S-2-S VPN users
If different from the LAN, is the address included in the ACL (interesting traffic)
0
Hey MSSPs! What's your total cost of ownership?

WEBINAR: Managed security service providers often deploy & manage products from a variety of solution vendors. But is this really the best approach when it comes to saving time AND money? Join us on Aug. 15th to learn how you can improve your total cost of ownership today!

atsandersAuthor Commented:
Thanks for the response Akinsd.
Yes. Users can ping Terminal Servers local IP. They have complete access to TS files and resources
Both LAN's are in different Subnets
John - Both External/WAN IP's are different
861 router has access-list permit IP from 2911 LAN
2911 router has access-list permit IP from 861 LAN

I found a couple of posts stating Split-DNS must be configured and Crypto level 3DES must be used. Both are configured.
Any other thoughts?
Thanks!
Chip
0
JohnBusiness Consultant (Owner)Commented:
Users can ping Terminal Servers local IP

Tunnel is up and you cannot access resources:   What happens (what error) for the following:

NET USE  T: \\IP Address of resource\folder name and authenticate. What error.
0
atsandersAuthor Commented:
Hi John,
Tunnel is fine. Users CAN access resources and map drives.
Issue is:  Users behind 861 ARE NOT able to establish RDP connection to Terminal Server IF they use Terminal Server  LAN IP address, as in: 10.11.X.X:3389.  Receiving “Remote Desktop Can’t connect to the remote computer” ….  Error.

 Users behind 861 ARE able to establish RDP connection to Terminal Server IF they use Public/Wan IP address, as in: 172.164.x.x:3389.

What I'm trying to accomplish is users must utilize RDP to Terminal Server over VPN. I want to close RDP Port access from WAN. We had a security related issue with RDP from WAN.

Thanks!
Chip
0
ffleismaSenior Network EngineerCommented:
You might want to look into the NAT configuration of your 2911 & 861

Since you mentioned the TS server is being accessed via public IP (172.164.x.x:3389), this means most likely you have a configuration for port forwarding/NAT between 10.11.X.X:3389 | 172.164.x.x:3389

Depending on how the port forwarding and general NATing is configured, you might need to replace/remove it to enable direct communication between Site-861 and Site-2911.

If you could share your sanitized configuration for Site-2911 (where TS reside) & Site-861, more specifically relating to NAT, VPN, ACL, experts might be able to better assist you on the configuration.
0
ffleismaSenior Network EngineerCommented:
I did a simulation on a similar setup with what you describe. Diagram and configuration is shown below
Simulation Diagram
hostname Home-R1
!
interface Ethernet0/0
 ip address 10.11.1.1 255.255.255.0
 ip nat inside
!
interface Ethernet0/1
 ip address 172.164.1.1 255.255.255.0
 ip nat outside
 crypto map To_REMOTE
!
ip route 0.0.0.0 0.0.0.0 172.164.1.2

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
VPN CONFIGURATION
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
access-list 150 permit ip 10.11.1.0 0.0.0.255 192.168.1.0 0.0.0.255
!
crypto isakmp policy 10
 encr aes 256
 authentication pre-share
 group 5
 lifetime 3600
crypto isakmp key vpn-password address 1.1.1.1
!
crypto ipsec security-association lifetime seconds 1800
!
crypto ipsec transform-set ESP-AES256-SHA esp-aes 256 esp-sha-hmac
!
crypto map To_REMOTE 10 ipsec-isakmp
 set peer 1.1.1.1
 set transform-set ESP-AES256-SHA
 match address 150

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
NAT CONFIGURATION
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
access-list 100 deny   ip 10.11.1.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 100 permit ip 10.11.1.0 0.0.0.255 any
!
ip nat inside source list 100 interface Ethernet0/1 overload

Open in new window

important bit here is the NAT configuration.
the deny statement prevents the TS server 10.11.x.x from being NATed to the public IP 172.164.x.x IF traffic is going towards remote-subnet
the second ACL line ensures that subnet 10.11.x.x can still reach the internet and it is NATed to the public IP of the router 172.164.x.x
hostname Remote-R1
!
interface Ethernet0/0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
!
interface Ethernet0/1
 ip address 1.1.1.1 255.255.255.0
 ip nat outside
 crypto map TO_HOME
!
ip route 0.0.0.0 0.0.0.0 1.1.1.2

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
VPN CONFIGURATION
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
access-list 150 permit ip 192.168.1.0 0.0.0.255 10.11.1.0 0.0.0.255
!
crypto isakmp policy 10
 encr aes 256
 authentication pre-share
 group 5
 lifetime 3600
crypto isakmp key vpn-password address 172.164.1.1
!
crypto ipsec security-association lifetime seconds 1800
!
crypto ipsec transform-set ESP-AES256-SHA esp-aes 256 esp-sha-hmac
!
crypto map TO_HOME 10 ipsec-isakmp
 set peer 172.164.1.1
 set transform-set ESP-AES256-SHA
 match address 150

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
NAT CONFIGURATION
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
!
access-list 100 deny   ip 192.168.1.0 0.0.0.255 host 10.11.1.100
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
!
ip nat inside source list 100 interface Ethernet0/1 overload

Open in new window

With this setup I could reach the internal IP of the TS and not via the public IP.

Your current setup probably will have something similar to this
Home-R1(config)#do show run | inc nat
 ip nat inside
 ip nat outside
ip nat inside source list 100 interface Ethernet0/1 overload
ip nat inside source static tcp 10.11.1.100 3389 172.164.1.1 3389 extendable

Open in new window

in which case, on the simulation I've run, the TS will be reachable only via the public ip 172.164.x.x instead of 10.11.x.x

Sorry for the long post, and hope this helps you out. Regards.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
atsandersAuthor Commented:
WOW Ffieisma. Outstanding response. Thanks for the time, effort, and such detail. I'm out of the office. Will take a look ASAP.
Chip
0
atsandersAuthor Commented:
I apologize for the delay ffleisma. Your assumption and resolution were right on. Issue has been resolved. Outstanding detail and support.
Thanks for your help ffleisma!
Chip
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.