We help IT Professionals succeed at work.

CPU is pegging up to 99% for about 15 minutes each time on start-up. How can I fix this?

joukiejouk
joukiejouk asked
on
Each time when i start my computer, the CPU increased to 99% and the system is extremely sluggish to where I cannot even do anything for about 15 minutes. The first screenshot shows my system specs. The second shows "Service Host: Network Service" consuming alot of the CPU on start-up. After about 5 minutes, the third screenshot shows "AutoKMS" consuming a lot of CPU as well. What can I do to resolve this? What is AutoKMS, and why does it always appear?

pc specs
cpu2
cpu2
Comment
Watch Question

dbruntonQuid, Me Anxius Sum?  Illegitimi non carborundum.

Commented:
AutoKMS may either be a legal activator for Microsoft Office or a hack tool for activating an unregistered version for Microsoft Office.

http://www.microsoft.com/security/portal/threat/Encyclopedia/Entry.aspx?Name=HackTool:Win32/AutoKMS

Try running a good anti-virus over your system as recommended by the link.

Author

Commented:
In my case, it's legit.
Most Valuable Expert 2013

Commented:
Are you connected to the domain/KMS server? It looks like your machine is looking to verify its activation state but can't see it.
Quid, Me Anxius Sum?  Illegitimi non carborundum.
Commented:
Which folder is AutoKMS in?
Most Valuable Expert 2013

Commented:
Good point db, legitimacy is in the eye of the beholder :)  

A rogue copy of AutoKMS can also mimic the legitimate file.
Gary CaseRetired
Most Valuable Expert 2013
Top Expert 2009

Commented:
Two things to do:

(1)  Check your automatic network logons and disable any that aren't always available.   This is likely what's causing your initial delay.

(2)  Run MSConfig and disable AutoKMS from starting -- then confirm that your issue goes away.

That will confirm that it's spending an inordinate amount of time trying to either establish connectivity with a network resource or doing "rogue" things via a malicious copy of AutoKMS.
Top Expert 2013

Commented:
you can also run msconfig  -
select the startup tab, and click disable all
reboot, and check -  if the problem is gone, enable the programs 1 by 1 or in groups to find the culprit