Cannot activate Sharepoint server publishing feature

Recently performed upgraded from Sharepoint 2010 to Sharepoint 2013 using database upgrade method. Under top level site collection I have Sharepoint Server publishing Infrastructure is enabled , however when I try to activate SharePoint server publishing feature I get content type not found 2a9ef51-737b-4ff2-9346-694633fe4416 error.

How to resolve this issue without performing the migration again. Also this is crucial because all content types are missing like task, item, Announcement under List content types.
buzzme123Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mohit NairSenior AssociateCommented:
Could you please try creating site collection and try activating the feature there ? I am just trying to figure out if its a problem with the whole farm or only that specific site.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SharePoint

From novice to tech pro — start learning today.