linking outlook remotely to exchange

Hi, I want to link a remote office that has outlook clients to our exchange at head office, so that when they open outlook locally for them they can access their mail accounts using outlook.

I read some articles and tried to set up the machines using http it seemed straightforward but i couldn't get it to connect.

We have a sbs2010 server and the clients are running outlook 2007 and are mainly windows 7 machines

I have checked the settings and have used

the exchange server address as mail.censura.co.uk

this is the same address they use to access their mail via the ows ie https://mail.censura.co.uk/ows

which works fine with their login credentials

we have a ssl certificate so i clicked the ssl and added mail.censura.co.uk in their i also tried just censura.co.uk the domain name but all no good

Each time i open up outlook i get it asking for login details and when added (which are again as per remote ows login and work fine using remote)

One issue

The domain their computers are logged in to their network is academygroupuk.com

while the domain the server is on is censura.co.uk

Not sure if this is an issue or not

Help please
censuraAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
Do you have Autodiscover DNS records setup?
If not, then that is probably the problem. You need to get the full DNS configured.
If Autodiscover.example.com is not on the SSL certificate, then it will probably have to be SRV records with your external DNS provider.

I would also create a test account and then run it through the Microsoft test site at http://exrca.com/ - it is the Outlook Anywhere tests that you are doing.

Simon.
0
Will SzymkowskiSenior Solution ArchitectCommented:
link a remote office that has outlook clients to our exchange at head office

If this is a remote office and you have a VPN tunnel from the Head Office to the Remote office and the machines at the remote office are added to your domain you do not need any of the above configuration done on these clients.

You will also need to ensure that the Outlook is configured for Negotiate Authentication.

If this is all set properly the clients at the remote office will have no issues connecting to Outlook.

You need to ensure that the clients at the remote office are also using the DNS of the Head Office DNS server, unless they have one local to them.

Will.
0
it_saigeDeveloperCommented:
Simon's option is really your best option.  It really is not a difficult task to get Outlook Anywhere up and running (ultimately, this is the purpose that Outlook Anywhere was designed for).

The VPN route would work if the DNS servers have records for both domains or the domains have a trust relationship.

-saige-
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

censuraAuthor Commented:
Ok i have gone into my domain hosting and added a  CNAME record

autodiscover.censura.co.uk

mail.censura.co.uk
0
censuraAuthor Commented:
also performed connectivity test - it failed (although i only just set up cname record 10min ago so maybe this is the reason. I checked ports and says both are opening and listening so not sure why i go this error

Attempting to resolve the host name i-tech-sys.com in DNS.
       The host name resolved successfully.
       
      Additional Details
      Testing TCP port 443 on host i-tech-sys.com to ensure it's listening and open.
       The specified port is either blocked, not listening, or not producing the expected response.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       
A network error occurred while communicating with the remote host.
Elapsed Time: 21037 ms.
0
Simon Butler (Sembee)ConsultantCommented:
A CNAME isn't going to work unless you have autodiscover.censura.co.uk in your SSL certificate, because it will fail with the Autodiscover process on SSL trust.
Just checking the certificate, you haven't got that host name in there. Therefore you need to set an SRV record, as I previously said. http://semb.ee/srv

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
it_saigeDeveloperCommented:
You mention censura.co.uk as your base domain but the test says that it is trying to resolve i-tech-sys.com.  What Subject Names do you have assigned to your certificate?

-saige-
0
censuraAuthor Commented:
ok i have set up srv record now
0
censuraAuthor Commented:
i did test and got this i am guessing i will have to wait for dns changes

      
      Test Steps
       
      Attempting to test potential Autodiscover URL https://censura.co.uk:443/Autodiscover/Autodiscover.xml
       Testing of this potential Autodiscover URL failed.
       
      Additional Details
       
      Test Steps
       
      Attempting to resolve the host name censura.co.uk in DNS.
       The host name resolved successfully.
       
      Additional Details
      Testing TCP port 443 on host censura.co.uk to ensure it's listening and open.
       The port was opened successfully.
       
      Additional Details
      Testing the SSL certificate to make sure it's valid.
       The SSL certificate failed one or more certificate validation checks.
       
      Additional Details
       
      Test Steps
       
      The Microsoft Connectivity Analyzer is attempting to obtain the SSL certificate from remote server censura.co.uk on port 443.
       The Microsoft Connectivity Analyzer successfully obtained the remote SSL certificate.
       
      Additional Details
      Validating the certificate name.
       Certificate name validation failed.
        Tell me more about this issue and how to resolve it
       
      Additional Details
       
Host name censura.co.uk doesn't match any name found on the server certificate E=ssl@vps3764.webhosting.uk.com, CN=vps3764.webhosting.uk.com.
Elapsed Time: 1 ms.
0
Simon Butler (Sembee)ConsultantCommented:
That error is nothing to do with your DNS changes.
It should have carried on, because Autodiscover first attempts to connect to the route of your domain (https://example.com/Autodiscover/Autodiscover.xml). When that fails it should then continue to the other options.

In this case, it could be that the web host's control panel is getting in the way. Some of the major web hosting control panels use Autodiscover for their own purposes, which causes problems. The feature needs to be turned off for your domain, which is done by the web host. Will probably take a few minutes before you get someone who understands the request though.

Simon.
0
censuraAuthor Commented:
Ok auto discovery test worked
0
censuraAuthor Commented:
Great all works fine now thank you for your help
0
censuraAuthor Commented:
A great help, thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SSL / HTTPS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.