Default permission to ftp users using vsftpd

Hi Experts, I need create default permission 775 when a made a upload of a file with my ftp client.
1 - I created a group caled ftpusers
2 - I created a folder in /var/www/my_user
2 - Add users to group and the directory /var/www/my_user
3 - Assign the permissions: chown my_user:ftpusers /var/www/my_user
chmod 775 /var/www/my_user

But when I upload a file the permission is set to 664, and I need 775
I am using Ubuntu 14.04

Some idea ? Thanks
alpiresAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joseph GanSystem AdminCommented:
What is your current umask?

# umask

You may need to change it to 0002.
0
Duncan RoeSoftware DeveloperCommented:
You want ftp to set execute permissions? I really don't think you can do that.
0
SandyCommented:
modify the umask in /etc/vsftpd/vsftpd.conf

TY/SA
0
Duncan RoeSoftware DeveloperCommented:
umask prevents bits from being set. E.g. 002 turns off Other write bit. But it does not turn on bits that are otherwise off (Execute bits in your case).
With local_umask=002 in your vsftpd.conf you could get 664 permission. Why do you want 775?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Duncan RoeSoftware DeveloperCommented:
To definitively answer your original question: no unmodified ftp server is going to set execute permissions on received files, so the best you can do is as per my previous post http:#a40672802
You could, if you wish, modify the source of your ftp server of choice to set execute permissions (i.e. to get 0775 instead of 0664) - that's the beauty of open source software.
If you don't personally have the skill set for that job, you could hire someone who has.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.