We help IT Professionals succeed at work.
Get Started

Attempting to import new SSL Certificate for Exchange 2010

Philip Cyr
Philip Cyr asked
on
202 Views
Last Modified: 2015-03-11
I am attempting to install a new certificate on an Exchange 2010 server.  Our current certificate expires today.  

I previously tried to import the certificate and some how messed up so I started over but now I am getting an error "Cannot Import Certificate. A certificate with the thumbprint XXXX already exists."  

I have checked the certificate store and deleted it but it is still showing this error.  Searching on here I attempted to run the command remove-exchangecertificate -thumbprint XXX .  But getting an error that the PrivateKeyMissing.

Any ideas?
Comment
Watch Question
CERTIFIED EXPERT
Most Valuable Expert 2014
Commented:
This problem has been solved!
Unlock 1 Answer and 12 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE