IE11 in Windows 2012r2 RDS doesn't search favorites from Address bar anymore

We have an issue where staff that log into a Windows 2012RDS farm are unable to type the name of a favorite in the address bar and bring it up.  Example we have a Favorite named "Home" that goes to our Intranet.  If we set this as a favorite in 2008r2 RDS, Windows 8.1, or Windows 7 systems running IE 11 it brings up the Intranet.  If we type Home in the address bar of a Windows 2012r2 RDS system running IE 11, it brings up the Bing search results for home.  I thought I seen something where MS might have made a change to how IE runs in Windows 2012r2 that might have broke this option for us, but can't seem to locate that anywhere now.    

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Michael MachieIT SupervisorCommented:
There is a new setting that gets enabled automatically for 'Search in the address bar'. This setting was enabled by default when the machine updated to IE11.. very easy to fix...

1) Open your IE11
2) Open 'Manage Add-Ons' from the 'Settings' icon of IE11 (the little gear looking icon at the very top right next to the star icon)
3) Select 'Search Providers' from the left side in the section for 'Add-On Types'
4) In the center pane, highlight 'BING'.
5) With 'BING' highlighted, look at the lower section of the window.
6) DESELECT the option for 'Search in the address bar......'
7) SELECT 'Prevent programs from suggesting changes...'  (OPTIONAL)
8) Select 'Close'

You have now disabled 'Searching' in the address bar and this issue should now be gone. Repeat for all browsers and search engines.
YeoLyleAuthor Commented:
Unfortunately this didn't work for us.  By doing that it sets the "Go to an Intranet site for a single word entry in the Address bar".  Our shortcut doesn't match the path.  Example Home is the name of the shortcut, but the site is

Michael MachieIT SupervisorCommented:
My instructions were specific to disabling the Search function in the address bar. Disabling the search function should now allow you to type in your Internal server's address and go to it, without a bing search populating.

However, upon further research, I see you are seeing the 'bug'. below is a copy/paste from MS about this...
MS Tech Article

If users want to go directly to the intranet site, then they can either type http:// before the intranet site name or append / to the site name.

Alternatively, you can configure Internet Explorer to go to the intranet site directly by using one of the following methods.

Method 1: Using Tools menu in Internet Explorer:

Click Internet Options, click the Advanced tab, check the option Go to an intranet site for a single word entry in the Address bar.

Method 2: Using Group Policy:

Local or Domain Administrators can configure this setting by using Group Policy.

    Click Start, click Run, type gpedit.msc, and then click OK.
    Expand User Configuration, expand Administrative Templates, expand Windows Components, expand Internet Explorer.
    Then expand Internet Settings, expand Advanced Settings, expand Browsing, Set Go to an intranet site for a single word entry in the Address bar according to your desired settings. You have to update policies or restart the computer to apply changes.

Method 3: Using registry key:

Important :This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:

322756  How to back up and restore the registry in Windows

    Click Start, click Run, type regedit, and then click OK.
    Locate and then click the following registry subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main
    On the Edit menu, point to New, click DWORD Value, and then add the following registry value:
    Value Name:  GotoIntranetSiteForSingleWordEntry
    Value Type:  REG_DWORD
    Value Data:  1

Hopefully this will help you.
YeoLyleAuthor Commented:
Thanks Machienet, Unfortunately that fix didn't help us any because the Intranet site resolved to a different name and also used HTTPS instead of HTTP.  We did find the cause of the problem and it looks to be a Microsoft issue.

We tracked the issue down to having Redirected the "Favorites" folder to a network location.  When we reverted "Favorites" back to the default location the search from the Address bar worked again.  


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
YeoLyleAuthor Commented:
The issue was due to a redirected folder which we tracked down internally.  Since we could not find this situation anywhere on the Net we figured this might help someone else that attempts to use the redirected folder options.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.