NAT ACL With Multiple Port Range

Hi Experts!

Hope everyone is well?

Currently we have the following setup on our Gateway Router:-

interface FastEthernet0/0
 ip address 98.152.29.154 255.255.255.252
 ip access-group NAT-ACL in
 ip nat outside
 ip inspect tgefw out

interface FastEthernet0/1.101
 encapsulation dot1Q 101 native
 ip address 10.2.1.1 255.255.255.0
 ip helper-address 10.2.1.101
 ip helper-address 10.2.1.102
 ip nat inside
 ip virtual-reassembly
!
interface FastEthernet0/1.102
 encapsulation dot1Q 102
 ip address 10.2.2.1 255.255.255.0
 ip helper-address 10.2.2.20
 ip helper-address 10.2.2.21
 ip nat inside
 ip virtual-reassembly
!
ip nat inside source list NAT-ACL interface FastEthernet0/0 overload
ip nat inside source static tcp 10.2.1.101 80 98.152.29.154 80 extendable
!
ip access-list extended IPFW-ACL
 permit tcp any host 10.2.1.101 eq www
 permit tcp any any gt 1023 established
 permit tcp any any eq domain
 permit udp any any eq domain
 permit icmp any any administratively-prohibited
 permit icmp any any echo-reply
 permit icmp any any packet-too-big
 permit icmp any any time-exceeded
 permit icmp any any traceroute
 permit gre any any
 deny   ip any any log
!
ip access-list extended NAT-ACL
 permit ip 10.2.1.0 0.0.0.255 any
 permit ip 10.2.2.0 0.0.0.255 any
 permit ip 10.2.4.0 0.0.0.255 any
 permit ip 10.2.110.0 0.0.0.255 any
 permit ip 10.2.190.0 0.0.0.255 any
 permit ip 10.2.200.0 0.0.0.255 any

What i now need to do is open up a range of Ports - something like:-

ip nat inside source static tcp 10.2.1.101 ** Port 7060 - 8010 ** 98.152.29.154 ** Port 7060 - 8010 ** extendable.

How would i go about this as i cant seem to find anything that will allow it - other than typing out each port on its own?

Cheers
TME
LVL 1
TrustGroup-UAEAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

max_the_kingCommented:
Hi,

have you tried something like:

ip access-list extended yourACL
permit tcp any any range 7060 8010

hope this helps
max
0
TrustGroup-UAEAuthor Commented:
Hi Max The King,

Many Thanks for your reply. Its not the ACL that is the rpoblem its this bit:-

ip nat inside source static tcp 10.2.1.101 ** Port 7060 - 8010 ** 98.152.29.154 ** Port 7060 - 8010 ** extendable.

you just cant seem to do Ranges?

Cheers
Si
0
max_the_kingCommented:
Hi, i am afraid there is no way to do that with nat statements
Max
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

TrustGroup-UAEAuthor Commented:
Hi Max The King,

Ah. Thats why i cant find anything then.

It there any work arounds to get around this then?

Cheers
TME
0
max_the_kingCommented:
Hi,
you may want to try something as suggested in the following link: it seems reasonable although you'll have to work a bit on it.

http://networkengineering.stackexchange.com/questions/2238/open-a-range-of-tcp-ports-in-cisco-ios-nat

let me know if it works for you
hope this helps
max
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TrustGroup-UAEAuthor Commented:
Hi Max!

Excellent. Just what i was after.

Cheers
TME
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.