ConnectionString property has not been initialized - DNN .NET apps broke after installing components from Microsoft's Web Platform Installer

I installed Microsoft's Web Platform Installer and two of my legacy .NET DNN modules don't work.  They get an error The ConnectionString property has not been initialized.   Any ideas?  I tried enabling 32 bit apps on the app pool and no luck.
gopher_49Asked:
Who is Participating?
 
sammySeltzerCommented:
Maybe, you add that component or create the connection string within WOW64 if you are using 64bit platform.

Windows -> SysWOW64.
0
 
gopher_49Author Commented:
It ended up being the below....  The developer changed the .vb files in the App_Code directory.  Not sure to what happened when I ran the installer but DNN is now running in .NET v4 even though it's told to use a .NET 2.0 app pool.  The reason I suspect this is due to the fact that the DNN event logs show a .NET assembly of v4.

Dim connString As String = System.Configuration.ConfigurationManager.ConnectionStrings("yourConnectionString").
0
 
gopher_49Author Commented:
I have to change the allow 32 bit apps AND modify my connection string in my custom module's vb control files.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.