Remote Access Virtual Machine VMware Workstation 11

Dear Experts,

Hope you are well.

I have one client computer and I connect via RDP to a remote Physical Server (Hosted on a Cloud Provider)
The Remote Physical Server, Win 2012 Server, has the IP: 64.205.10.x and is under Workgroup.

The Remote Physical Server has VMware Workstation 11 Installed with a Win 2012 VM ,IP: 192.168.1.1, connected via VMware’s NAT network.
Via VMware’s Virtual Network Editor I have created the below NAT rule in order to access the VM via RDP:
Host: 3390 / Type:TCP / VM IP: 192.168.1.1:3389

Now I can connect from my client via RDP to the Physical Remote Server and inside Physical Remote Server I can connect to VM via RDP by typing: 64.205.10.x:3390

What I want is to connect to the VM via RPD directly from the client computer (bypassing the RDP to the Physical Remote Server).

Any ideas??

Thanks in Advance,
Mamelas
mamelasAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You can either switch the VM networking to Bridged Mode, or use Advanced NAT to passthrough the RDP traffic to the VM, on the NAT network.
0
mamelasAuthor Commented:
Dear Andrew,

This VM is a part of a VM LAB. Switching to Bridge Mode I guess that it will isolate this VM from the rest VMs and such action is out of scope.

Could you please advise the required procedure of other two options? (please note that this is a cloud server thus managing the network outside this Server will require support from the provider and is not preferred)
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You will need to use Advanced NAT

see here

https://www.vmware.com/support/ws3/doc/ws32_network21.html

or easier, startup the Virtual Network Editor, and select NAT network, NAT Settingd, and then add Host Port, Virtual Machine IP Address.

this port forward should allow you to connect via RDP to the VM in the NAT network.

Virtual Netwotk Editor
Virtual Network Editor
Make sure you select a host port, which is not in use, for the port forward.

and then RDP to IP Address of the Host : 3390, this will port forward.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

mamelasAuthor Commented:
The above procedure of editing VMware's Virtual Network is already done and I can connect to VM from Remote Server.
But I cannot connect using RDP with the same ip/port from my Client PC.
I assume that another DNAT is required to be done to the Remote Physical Server but I don't know where and how to configure:

I have created a drawing for your convinience:
Required Connection Diagram
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
You cannot go directly to the VM, when the VM is on NAT, you must port forward from the host.

So....

if the Host IP Address is 62.205.10.x, 3389 is RDP, and 3390 (NAT port) should allow access to the VM.
0
mamelasAuthor Commented:
Yes this is correct but I have 2 Hosts as per above diagram.
Host1: my client computer
Host2: Remote Server

Host1 connects to Host2 via RDP (ip: 62.205.10.x) - no special setting here, just enabled the RDP service on Host2
Given that I am already connected  via RDP to Host2, from Host2 I use again the RDP to connect to VM using NAT (ip: 62.205.10.x and port 3390)

Therefore Host2 is between Host1 and VM.

So Using RDP from Host1 I need a port forward in order to connect to the VM using the Static IP of Host2.
the question is how and where?
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
okay, what is the IP Address of the VMware Workstation 11 Host ? (which hosts the VM you need to RDP to!)

at present your RDP to the VMware Workstation host, using RDP 3389

if you use the same IP Address, but port 3390 this will connect to the VM which is hosted on host2?

is this what you want to do?
0
mamelasAuthor Commented:
Host2 is the Physical Remote Server that has VMware Worstation 11 installed.
The local IP of this server is the 62.205.10.x which is also the static ip address for connecting remotly to this Server.

The VM that lives inside Host2 has the 192.168.1.1

So using my "local ip" which is again the 62.205.10.x and the port 3390 I can connect from Host2 to VM.
But this is not working on my remote computer which is Host1.
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
62.205.10.x and the port 3390 will allow connection to the VM, provided you have access, and have made the configuration changes on NAT Settings.

This can be tested on server  62.205.10.x, if you launch an RDP connection to...itself, even 127.0.0.1:3390 does this connect to the VM, to check this part is working.
0
mamelasAuthor Commented:
I think there is a misunderstanding here and I apologize for this.

Inside Host2 resides VMware Workstation and subject VM

In order to connect to the VM via RDP I need to follow the below procedure:

  a)From my client computer (Host1) I open RDP Client and I type the 62.205.10.x
  b)Now I am connected via RDP to the Remote Physical Server, Host2
  c)Inside Host2 I open the RDP Client and I type one of the below IPs:
     - 192.168.1.1
     - 127.0.0.1:3390
     - 62.205.10.x:3390
All the above IPs connect me successfully to the VM.

Now, I need to create a port forward (I guess to Host2) in order to
connect to VM via RDP directly from my client computer (currently it is a nested configuration which requires 2 RDP connections -one inside another)
0
Andrew Hancock (VMware vExpert / EE MVE^2)VMware and Virtualization ConsultantCommented:
okay, so we know that the Advanced NAT configuration is working correctly.

so why is 62.205.10.x:3390 not available from your client computer ?

if host1 can connect to 62.205.10.x:3389, why can it not connect to  62.205.10.x:3390?

same IP but different port ?

is this because the client computer is external on the internet ?
0
mamelasAuthor Commented:
okay, so we know that the Advanced NAT configuration is working correctly
I would say that the "NAT Settings" of VMware's "Virtual Network Editor" work correctly inside the Host2

if host1 can connect to 62.205.10.x:3389, why can it not connect to  62.205.10.x:3390?
yes Host1 connects successfully to 62.205.10.x:3389 but refuses connection to 62.205.10.x:3390

is this because the client computer is external on the internet ?
I make the assumption that inside Host2 the VMware Workstation's NAT "translates" the 62.205.10.x:3390 to 192.168.1.1:3389.
It is same when i ping from the Host2 the VM and I get replies.Even if the two machines are on different networks
the can communicate each other successfully.

Therefore the subject question is how to create the NAT/Port that connects the external client Host1 to the VM    
through the Host2...
0
mamelasAuthor Commented:
Dear Andrew,

Finally I made it and I will share it with you right away:

Windows Firewall was Enabled on the Host2.
Firstly I disabled the Firewall and I noticed that I could now connect directly to VM from Host1 with the IP 62.205.10.x:3390
Then I enabled again the Firewall and I created and Inbound Port rule by specifying the port 3390

Now I can successfully connect to the VM directly from my remote client PC with the IP 62.205.10.x:3390!

Thanks for you help,
Mamelas
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mamelasAuthor Commented:
Inbound Port rule was required in Windows Server Firewall on the Remote Physical Server (Host2)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.