Exchange 2013 ActiveSync Not Working

I have an Exchange 2013 server running in my environment.  I have recently had to change the IP address of the server.  I have changed the host (a) records and updated pointer records.  _autodiscover also points to the dns host record and not the IP address.  Everything seems to be operating correctly except ActiveSync.  I did an nslookup on my server and it comes back to the right address.  I have run the Remote Connectivity Analyzer on ActiveSync and it comes back with the following errors.

Attempting to test potential Autodiscover URL https://domain.com:443/Autodiscover/Autodiscover.xml
Testing of this potential Autodiscover URL failed.

Attempting to test potential Autodiscover URL https://autodiscover.mail.com:443/Autodiscover/Autodiscover.xml
Testing of this potential Autodiscover URL failed.

Attempting to contact the Autodiscover service using the HTTP redirect method.
The attempt to contact Autodiscover using the HTTP Redirect method failed.

Attempting to contact the Autodiscover service using the DNS SRV redirect method.
The Microsoft Connectivity Analyzer failed to contact the Autodiscover service using the DNS SRV redirect method.

Everything in DNS seems to be correct.  What am I missing?

Thanks.
ollybubaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Simon Butler (Sembee)ConsultantCommented:
"Attempting to contact the Autodiscover service using the DNS SRV redirect method.
 The Microsoft Connectivity Analyzer failed to contact the Autodiscover service using the DNS SRV redirect method."

Your SRV records cannot be correct.

Although that shouldn't stop ActiveSync from working, because ActiveSync rarely uses Autodiscover (most ActiveSync devices don't support it correctly). Therefore you should do the test that allows you to manually enter the server address, rather than using Autodiscover.

Simon.
0
ollybubaAuthor Commented:
So change my SRV record to an IP address or what do you mean?
0
Simon Butler (Sembee)ConsultantCommented:
I don't know what you have the setting to at the moment. An SRV record though is usually a host name. However the error you have posted tends to suggest that you have the name of the record wrong.

http://semb.ee/srv

Simon.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

ollybubaAuthor Commented:
The _autodiscover SRV record is:

Domain: domain.com
Service: _autodiscover
Protocol: _tcp
Priority: 0
Weight: 0
Port Number: 443
Host offering this service: exchangeserver.domain.com
0
ollybubaAuthor Commented:
I changed the "Host offering this service" to the IP address and it still comes back with the same errors.  Could it be something in IIS?
0
Simon Butler (Sembee)ConsultantCommented:
That is in your EXTERNAL DNS?
As the error being reported means the testing service cannot see your DNS record.
Have you checked with one of the numerous external DNS testing services to see if the Autodiscover SRV record is seen?

Simon.
0
ollybubaAuthor Commented:
I just figured out what the problem is.  I changed the IP for port 25 but not 443.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ollybubaAuthor Commented:
While looking at my external DNS I had forgotten to change port 443 to map to the new IP address of the Exchange server.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.