Cannot Copy Cisco Router Config via TFTP to TFTP Server on Windows 2008 R2 Server

I am using TFTPD64 on a Windows 2008R2 Server. I am trying to simply copy TFTP configs from routers/switches to this server. I have made sure that the Everyone group has full control file permissions of the TFPT Root Folder but when I attempt to copy the config of the switch via tftp I get this message (IP address changed):

%Error opening tftp://192.168.1.100/switchconfig (Illegal protocol operation)


I have even disabled the Firewall service to make sure that isn't an issue. Any advice on this would be greatly appreciated.
LVL 1
Rob SandersAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bominthuCommented:
Are you able to ping the server IP from cisco router ?

If yes, can you try changing TFTP folder to your "My Documents" folder instead ?
0
Don JohnstonInstructorCommented:
"illegal protocol operation" usually means IP isn't enabled.  Do you have an IPv4 address assigned to the switch?
0
Rob SandersAuthor Commented:
Yes, i am able to ping the server without issue and I can even TFTP transfer to a workstation that is on the same LAN as the router.

I tried changing the folder to the My Documents folder as suggested but it made no difference.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Rob SandersAuthor Commented:
Don,
 Yes an IP address is assigned to the switch and I have successfully made a TFTP transfer from the switch to a workstation that is on the same LAN as the Windows 2008 R2 server.

For some clarity, i realize i have gone back between router and switch when discussing this problem. I am primarily focused on getting the TFTP server functioning on the Windows 2008 R2 server so that I can regularly TFTP file copy to and from it. I have tried from both a switch and router to make this happen but run into the "illegal protocol operation" error in both cases.

Also, both the switch and router are able to TFTP copy to a workstation on the same LAN as the Windows 2008 R2 server without issue.
0
FideliusCommented:
Did you try to do it with just:
# copy run tftp://192.168.1.100/

And follow the prompts to enter file name.

Regards!
0
Rob SandersAuthor Commented:
Fidelius,
 Thank you for the suggestion. I get the same "Illegal protocol . . ." error even when using the #copy run tftp://192.168.1.100/ format.
0
FideliusCommented:
Can you try with different TFTP server just to be sure it is not some issue with tftpd64.
Here is TFTP server I usually use: http://www.firewall.cx/downloads/16-1-3cdaemon-server-a-client.html?path=
0
Rob SandersAuthor Commented:
Trying right now. I will post results shortly.
0
Rob SandersAuthor Commented:
Argh! Same problem even with 3CDaemon TFTP.
0
FideliusCommented:
Under TFTPD64 Settings, go to TFTP tab, and select this options:
TFTP settings
0
Rob SandersAuthor Commented:
Making those changes did not make a difference. However, I did get the following message after I made the change and went to restart TFTPd64:

"Bind error 10013
An attempt was made to access a socket in a way forbidden by its access permissions. 192.168.100.25"

and then all I can do is click Ok.

192.168.24.25 is the IP address of the Windows 2008 R2 server that I am try binding the TFTP software to.

In the log viewer it shows:

Error : socket returns 10022: <An invalid argument was supplied.> [13/03 09:16:16.311]
Error : socket returns 10022: <An invalid argument was supplied.> [13/03 09:16:16.311]
0
FideliusCommented:
Close TFTPD64, and try to run it as Administrator (right-click "Run as administrator...").
Also check that something else is not listening on UDP/69 port.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rob SandersAuthor Commented:
hmm, we might be on to something. It looks like I have wdsserver running on port 69.

Could I make the switch/router tftp on a different port?
0
Rob SandersAuthor Commented:
Fidelius, you are a genius. I disabled that service temporarily so that port 69 was available for TFTP and that fixed the issue.

I will probably just install the TFTP software on a different server that doesn't need to use port 69 so I don't run into this problem.

Thank you so much for the assistance.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.