Can't See External Website Internally

I have a company that had a website hosted externally with a private party. We have moved the website to a new host (still outside my local network) and I updated my Network Solutions DNS to point to the new host. From outside my network I can see the website just fine but none of the computers in my domain can see the website. I checked the local DNS servers and found an “*” and  “WWW” record pointing to the old IP, I have changed the IP to reflect the new IP address and if I ping the website it is resolving to the correct IP address but still can’t access the website internally. I also read somewhere since the website is hosted externally I should not have a "*" or a "WWW" record locally but after deleting them I still can't access the site. Any Idea’s of what could be going on?
seg-supportCEOAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Greg HejlPrincipal ConsultantCommented:
Your internal DNS should have your www record pointing to the new IP.

You probably need to flush your local DNS too - ipconfig /flushdns
0
seg-supportCEOAuthor Commented:
I tried both of those. Weather the record is there or not I can Ping the website and it is resolving to the correct IP but not browse-able through Internet Explorer or Chrome on internal network.
0
Greg HejlPrincipal ConsultantCommented:
have you reboot your computer yet?  the browsers may be caching the old IP
0
Top Threats of Q1 & How to Defend Against Them

WEBINAR: Join WatchGuard CTO and our Threat Research Team on Aug. 2nd to hear the findings from our Q1 Internet Security Report! Learn more about the top threats detected in the first quarter and how you can defend your business against them!

David Johnson, CD, MVPOwnerCommented:
you also have to clear the dns servers cache.clear dns servers cache
powershell to clear ALL DC's cache  (remove the -whatif if it will do what you want)
$DCS = Get-ADDomainController
foreach ($dc in $dcs) {
Clear-DnsServerCache –ComputerName $dc.hostname -Force -whatif
}

Open in new window

0
seg-supportCEOAuthor Commented:
I have rebooted the pc's as well as cleared the DNS Cache on the server.
0
seg-supportCEOAuthor Commented:
I have also rebooted the DNS server. When I ping the website it is resolving to the correct IP address so the DNS appears to be working but when I browse the page it comes up and says "webpage is not available" or "Internet Explorer cant display the webpage".
0
Greg HejlPrincipal ConsultantCommented:
http://www.downforeveryoneorjustme.com/

can you browse to it from your DNS server?  

If you can access this from outside your network and cannot from inside your network there is a configuration issue inside your network.

Have you checked the hosts or lmhosts file on your local machine?  this is the first place the LM looks for DNS info.
0
seg-supportCEOAuthor Commented:
When I check the website on your tool it says it’s just me, the site is up. No I can not access the site on my local dns server, I get the same error as the pc's. I have checked the hosts files there are no records in there, its the standard examples from Microsoft. Am I correct in thinking that if I can ping the www.mycomany.com on the local pc and it resolves to the correct IP that my website is hosted on that this is not a DNS issue?
0
DrDave242Commented:
Since you mentioned that you had a www record on your internal DNS server, does your internal (AD) domain have the same name as your external (registered) domain?
0
seg-supportCEOAuthor Commented:
Minus the .com yes. For example my website is www.mycompany.com and my internal domain is mycompany.local
0
DrDave242Commented:
OK, that's good, as those are considered different domain names. Is there a forward lookup zone named mycompany.com on your internal DNS server?
0
seg-supportCEOAuthor Commented:
Yes under Forward lookup Zones I have a mycompany.com and a mycompany.local
0
DrDave242Commented:
Are the any records in the mycompany.com zone? You mentioned deleting the www record, but is it still gone, or did you recreate it?

If the zone is empty, delete it altogether, then flush the resolver cache on a client (ipconfig /flushdns) and try to reach the website again.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
seg-supportCEOAuthor Commented:
There is a www record and a mail record but then I look under mycompany.local the records are there also.
Capture.PNG
0
seg-supportCEOAuthor Commented:
When I go to delete the zone i get this.  Capture3.PNG
I looked at the Active Directory and it only shows mycompany.local not the mycompany.com so I should be OK to delete correct?
0
DrDave242Commented:
Yeah, you can delete that. It just means that the zone is stored in AD; it's not related to your actual AD domain.
0
seg-supportCEOAuthor Commented:
So I deleted the Zone and flushed and registered the dnd and i was able to hit the website inside the building. Weird thing is if I go to www.mycompany.com the page doesn't come up but if i go to mycompany.com the page loads? I checked the mycompnay.local and the www record is there with the correct IP?
0
DrDave242Commented:
Ignore that www record in the mycompany.local zone. In fact, you can probably delete that record unless you've also got an internal site named www.mycompany.local.

It sounds like the website is configured to only respond to requests for mycompany.com but not www.mycompany.com. If that's the case, the site host will likely have to be the one to fix it (and it should be a simple fix). Do you know whether both URLs work from outside the office? If they do, that's...strange.
0
seg-supportCEOAuthor Commented:
When I type www.mycompany.com into the outside it translates to mycompany.com and the website page opens.
0
DrDave242Commented:
OK, the site is redirecting the request. That's normal, but it should work the same from inside or outside your office. Just to make sure you don't have a bad DNS record cached somewhere internally, clear the server cache on all of your internal DNS servers, either by using the console or PowerShell as posted by David Johnson above or by running dnscmd /clearcache on each one. Then run ipconfig /flushdns on your client once again and try to reach the site at www.mycompany.com.
0
seg-supportCEOAuthor Commented:
That Looks like it fixed it, Thanks for all the help.
0
Greg HejlPrincipal ConsultantCommented:
Let's use Telnet.

can you packet trace at your firewall?  check port 80/443 rules pointing to your domain site/IP of the web host.  

if you can ping the webhost IP using the domain name, then your DNS is OK.

try >telnet mycompany.com 80  you should get a black screen if the connection is successful

if not check your packet trace to see where the TCP comms are failing.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.