Link to home
Create AccountLog in
Avatar of MichaelBalack
MichaelBalackFlag for Singapore

asked on

Autodiscover failed, how to get it resolved?

This is using 2 MS Exchange 2010 servers, 1 being the CAS, and another one is MB/Hub. Autodiscover used to work until probably 3 months ago. It was found not working as we have to resort to manual settings keyin instead of automatic configured. Both exchange servers using SP3

I checked the Microsoft remote test connectivity test, and the result is failed. Please see the results as attached.
The 2nd test is, I using Test Email Autoconfiguration, it also failed. 3rd test, browse to, and result with error - 600. But, other features - OWA, Outlookanywhere, and others are working fine. What could be the problem, and how to solve it?

thanks in advance.
Avatar of Patrick Bogers
Patrick Bogers
Flag of Netherlands image


This is the URL that fails... starting with https (implying port 443 i would think) so try to browse to this URL with a browser and make some changes in the adress until it finds the right xml file.

This you need to adjust in exchange.

BTW: Http 600 means autodiscover service works so ignore that error.
Avatar of MichaelBalack


Hi Patricksr 1972,

BTW, how to make the necessary changes in Exchange?
Hi Michael,

Via the exchange powershell module, for a step by step click this link.

look for
Get-ClientAccessServer |fl identity,autodiscoverserviceinternaluri
Hi Patricksr1927,

The URL for autodiscover is present, nothing to change...
Ok, so what does outlook report when you test the service with only use autodiscover selected?
Hi Patricksr1972,

See my first article - attached testconnectivityresults.txt
Do you have a record in the DNS saying autodiscover?
Please rerun this test and uncheck the yellow marked options and show the log again.
User generated image
Avatar of MichaelBalack
Flag of Singapore image

Link to home
Create an account to see this answer
Signing up is free. No credit card required.
Create Account
The problem is on the IIS web site bindings. After the cleanup, autodiscover is working fine.