How can I rename or remove actxprxy.dll

I cannot install dragon 13 by Nuance due to a bad actxprxy.dll

I have no luck trying to rename that dll using cmd prompt under admin to do so and even in safe mode i cannot get access.    error= trustedinstaller(user) won't grant access or
error= The file ACTXPRXY.DLL did not register itself.

I have reregistered it  with cmd prmt and  got a succeed message but still no luick. get same error when I try to install

e.g steps I have done
1. Zipped up working dll from by other PC running same system
2) Unzip the actxprxy.dll file onto your computer’s hard drive
3) Browse to c:\Windows\System32
4) Locate the current actxprxy.dll on your system
5) Rename the current actxprxy.dll to actxprxyBACKUP.dll
6) Copy & paste the new actxprxy.dll into C:\Windows\System32
7) Click Start > Search type in "run" Win7 and hit enter
8 ) Typed “cmd” in the box that appears
9) Typed “regsvr32 actxprxy.dll” on the black screen


 scanned PC with zntivirues and malwarebytes and and all is clean

ran as admin cmd sfc /scannow

I also have tried to disable trusted installer with success but still I cannot rename actxprxy
need-permisioon.JPG
actx.JPG
webguy62Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

andreasSystem AdminCommented:
try to boot with a linux CD and copy over the file there. Make sure you have a working backup of your system b4 manipulating the OS with linux. If you make a mistake you can damage the windows to a degree its not fixable and needs a restore from backup.

Afterwards re register the dll after windows was boted up again.
nobusCommented:
Sebastian LennskogSystem consultant, Data centerCommented:
First of all, I would try to reinstall Direct X.
Otherwise, to remove the .dll you need to take ownership of it
by rightclicking -> Properties -> Security -> Advanced
choose change permissions and add your account.

Also, if the file is locked, you can download processexplorer from technet
https://technet.microsoft.com/en-us/sysinternals/bb896653.aspx
and see which processes are using the file.
Kill them and then remove/rename the file.
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

webguy62Author Commented:
Hi Guys

I tried nobus  solution's to no avail

After stopping by unlocking and pausing process that seemed to be running, (including win explorer) with actxprxy.dll I replaced it with new working file from my other PC running same OS and all same components cause I built them myself.

Still error when trying to open Dragon 13= The file ACTXPRXY.DLL did not register itself.

Now I will try Sebastian's  solution as I might have missed closing one of the processes although I was able to delete the file actxprxy.dll

Oh and I tired the righ clicking riun as admin and trying to change ownership but got same error =  error= trustedinstaller(user) won't grant access

I cannot even turn off trusted installer? After 20+ years working with windows I finally found the bug that is going to make me mad.
Sebastian LennskogSystem consultant, Data centerCommented:
Ohh, I thought of someting you could try also,

Not sure which version of IE you're running but let's say you're using IE10.
Remove IE10 from Add/Remove Windos features. Then  delete the actprxy.dll if still existing.
Download latest IE - version and install again. May solve it.

also reset all networkprotocols in CMD as admin:
netsh int ip reset
netsh winsock reset
shutdown -r -t 0 -f

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
webguy62Author Commented:
don't use IE since IE 3  :) I went with Netscape Gold . A long forgotten piece of software

However I was not able to install IE 10 to test a clients remark a few months ago and got error.  So This might  be the root of the problem

First I will clean up that IE mess

rather work on on of my servers running centos then windows ;)

Thanks and do think this is the solution
webguy62Author Commented:
Unbelievably easy :)  
I kept thinking that IE had something to do with that dll but I guess I needed a second opinion to move forward on that thought :) I hate it   when I ignore my own thoughts and stubbornly move forward blindly :)  All works fine now.  After unchecking  IE11 in Programs/Add?Remove Win Comp/ and rebooting. I am back in happyland;

Thanks
Sebastian LennskogSystem consultant, Data centerCommented:
Sweet!

Yeah, well I know how it is, sometimes you just can't figure it out and you think "It can't be that easy" hehe!
Glad you're back in  happyland!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.