HP pro curve DHCP vlans

Hi

clients in vlan 3 are not getting dhcp address. All the other vlans work correctly its just vlan 3 that isnt working. All the other vlans are using the sam dhcp server too.

The other Vlans are for wireless clients apart from Vlan1 and they get IP's from DHCP

here is the core config.

Running configuration:

; J8698A Configuration Editor; Created on release #K.15.16.0004
; Ver #06:74.fc.7f.ff.3f.ef:de
hostname "Core-01"
module 1 type j9534a
module 2 type j9536a
module 3 type j9534a
module 4 type j9534a
module 5 type j9550a
module 6 type j9550a
module 7 type j9550a
module 8 type j9546a
module 9 type j9550a
module 10 type j9550a
module 11 type j9538a
module 12 type j8706a
fault-finder broadcast-storm sensitivity high
fault-finder bad-driver sensitivity high
fault-finder bad-transceiver sensitivity high
fault-finder bad-cable sensitivity high
fault-finder too-long-cable sensitivity high
fault-finder over-bandwidth sensitivity high
fault-finder loss-of-link sensitivity high
fault-finder duplex-mismatch-hdx sensitivity high
fault-finder duplex-mismatch-fdx sensitivity high
fault-finder link-flap sensitivity high
trunk E24,F24,G24 trk1 trunk
trunk B21,K8 trk2 trunk
trunk J19-J20 trk3 trunk
trunk J21-J22 trk4 trunk
trunk J23-J24 trk5 trunk
trunk G19-G21 trk10 trunk
timesync sntp
ip default-gateway 172.16.100.1
ip directed-broadcast
ip route 0.0.0.0 0.0.0.0 172.16.100.1
ip route 172.16.0.0 255.255.255.0 172.16.0.1
ip routing
ip udp-bcast-forward
interface B20
   name "ICT Office Uplink"
   exit
interface E1
   lacp active
   name "Printers"
   exit
interface E2
   lacp active
   name "Printers"
   exit
interface E3
   name "Printers"
   exit
interface E4
   name "Printers"
   exit
interface E5
   name "Printers"
   exit
interface E6
   name "Printers"
   exit
interface E7
   name "Printers"
   exit
interface E8
   name "Printers"
   exit
interface E9
   name "Printers"
   exit
interface E10
   name "Printers"
   exit
interface F1
   lacp active
   exit
interface F2
   lacp active
   exit
interface G1
   lacp active
   exit
interface G2
   lacp active
   exit
interface G5
   name "Internet"
   exit
interface J19
   name "Trunk to Edge 01"
   exit
interface J20
   name "Trunk to Edge 01"
   exit
snmp-server community "public" unrestricted
snmp-server host 10.35.248.45 community "public"
snmp-server host 192.168.100.51 community "public"
snmp-server location "Server Room"
vlan 1
   name "DEFAULT_VLAN"
   no untagged F1-F23,G5
   untagged A9-A24,B1-B20,B22,C1-C24,D1-D24,E1-E23,G1-G4,G6-G18,G22-G23,H1-H8,I1-I24,J1-J18,K1-K7,L1-L24,Trk1-Trk5,Trk10
   tagged A1-A8
   ip address 10.35.248.130 255.255.252.0
   ip forward-protocol udp 10.36.15.255 7
   ip forward-protocol udp 10.36.15.255 9
   ip igmp
   exit
vlan 2
   name "WLAN_CLt"
   tagged A1-A8,B22
   ip address 10.36.0.1 255.255.248.0
   ip helper-address 10.35.248.41
   exit
vlan 3
   name "Wired_Clt"
   untagged F1-F23
   tagged A1-A8,E23,K1-K7,L1,Trk1-Trk5,Trk10
   ip address 10.36.8.1 255.255.248.0
   ip helper-address 10.35.248.41
   ip igmp
   exit
vlan 5
   name "SPC_IPADS"
   tagged A1-A8,B22
   ip address 10.36.16.1 255.255.248.0
   ip helper-address 10.35.248.41
   exit
vlan 6
   name "Sixthform_Wifi"
   tagged A1-A8,B22
   ip address 10.36.24.1 255.255.248.0
   ip helper-address 10.35.248.41
   exit
vlan 11
   name "Internet"
   tagged A1-A8,E23,K1-K7,L1,Trk1-Trk2,Trk10
   no ip address
   exit
vlan 12
   name "Internet_GW"
   untagged G5
   tagged A1-A8,E23,K1-K7,L1,Trk1-Trk2,Trk10
   ip address 172.16.100.2 255.255.255.0
   exit
vlan 13
   name "Mgmt_AP"
   untagged A1-A8
   tagged E23,K1-K7,L1,Trk1-Trk2,Trk10
   ip address 172.16.101.1 255.255.255.0
   ip helper-address 10.35.248.41
   exit
vlan 41
   name "Guest"
   tagged A1-A8,B22,E23,K1-K7,L1,Trk1-Trk2,Trk10
   ip address 172.16.0.1 255.255.248.0
   ip helper-address 10.35.248.41
   exit
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree Trk3 priority 4
spanning-tree Trk4 priority 4
spanning-tree Trk5 priority 4
spanning-tree Trk10 priority 4
no spanning-tree bpdu-throttle
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager
password operator
ful56ukAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Don JohnstonInstructorCommented:
I know this is going to sound like a dumb question but you would be surprised at how many times it's something this simple...

Is there a scope defined on the DHCP server for the 10.36.8.0 network?

If so, manually assign an IP address to a host on VLAN 3 and try to ping the DHCP server.  If that doesn't work, then you've got something stopping the IP traffic. Maybe an access-list.  Or there could be a firewall (either a device or a service running on the DHCP server) blocking the traffic.
0
ful56ukAuthor Commented:
Hi

Yes correct there is a scope defined on the DHCP and it is active

you can ping the dhcp too from one of those addresses. There is no firewall between the vlans
0
Don JohnstonInstructorCommented:
Well that's puzzling.  There's nothing on the config of the switch that would prevent it from working.

I would load a protocol analyzer (i.e. Wireshark) on a host and see if the DHCP requests are being sent.  Then load one on either the DHCP server or a host on that network (you'll need to use port monitoring) to verify that DHCP request are arriving at the server and that an offer is being sent.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Netman66Commented:
Double check the scope options.  Make sure the subnet mask and gateway are correct.

10.36.8.0/21 should have:

10.36.8.1 Gateway/Router
255.255.248.0 Subnet mask

I've seen this when the subnet mask in the scope doesn't match the vlan interface.
0
ful56ukAuthor Commented:
thats been doubled check too i can confirm this. i thought it was my config. plugged my pc into an untagged port on vlan 3 and it get an ip from Vlans 1 ip range
0
Don JohnstonInstructorCommented:
Wait a minute... You connect a host to a VLAN 3 port and it gets an IP address on the 10.35.248.130/22 network?
0
Netman66Commented:
Check the scope options on vlan 1 then.  Sounds like the subnet mask is huge.
0
Don JohnstonInstructorCommented:
Sorry, cut & paste error.

You connect a host to a VLAN 3 port and it gets an IP address on the 10.35.248.0/22 network?
0
ful56ukAuthor Commented:
That is correct yes my pc is on port f4 which is an untagged member of vlan3.
 
Vlan1 IP for the router on the dhcp scope options is the core switch which is 10.35.248.230 the ip of the switch config above
0
Don JohnstonInstructorCommented:
Just curious, what port is the DHCP server connected to?

This is really interesting.  Just to review:

1

A host with a statically assigned IP address on the 10.36.8.0/22 network and a DG of 10.36.8.1 can ping the DHCP server and other devices on other networks?

2

 A host configured for DHCP connected to the same port as above receives an IP address for the 10.35.248.0/22 network? Are all the other parameters (Mask, Default gateway, DNS, etc) consistent with a VLAN address?
There's absolutely no way that it should have any effect, but can you remove the "ip igmp" statement on VLAN3 temporarily?  It's the only thing different with VLAN3 and there could be a bug that is causing that command to create this symptom.
0
Netman66Commented:
Yeah, it's strange.  The only other thing I see that is odd is the trunk ports.  There are trunk bundles defined, some tagged and some not, but then there are port ranges being used to trunk (tagged) - can't say I get that without a drawing to look at.
0
Don JohnstonInstructorCommented:
Yeah... I saw that as well.  But I figured that since traffic was flowing with a static IP address then the trunks must be correctly configured.
0
Netman66Commented:
Well, traffic flow may not be a good indicator if it's routing all over the place.  Layer 3 should eventually find a path, but it may not be the one you desire.

Without some sort of network diagram, tracing this out is hit and miss at best.
0
Don JohnstonInstructorCommented:
Given that the DHCP server has an IP address of 10.35.248.41 and the VLAN1 interface of the switch is 10.35.248.130/22, I'm making the assumption that there is no routing between this switch and the DHCP server.

But I could be wrong.
0
Netman66Commented:
The DHCP server is on the same subnet based on the addresses provided.
0
ful56ukAuthor Commented:
Correct both core sw and dhcp in vlan 1 same subnet.

Answer to other questions.
1. Correct pinging no issue.
2.correct to and I'll remove the Igmp in a bit. Other thing I will try is create a new vlan and brick vlan3.

Other vlans work fine and get dhcp addresses from the correct defined scope on the same dhcp server.
0
Netman66Commented:
How are you routing between vlans at layer 3?
0
Don JohnstonInstructorCommented:
The 5412 has "ip routing" configured.
0
ful56ukAuthor Commented:
Here is the routing table

------------ ---- --------- ---------- ---------- -----
  0.0.0.0/0          172.16.100.1    12   static               1          1
  10.35.248.0/22     DEFAULT_VLAN    1    connected            1          0
  10.36.0.0/21       WLAN_CLt        2    connected            1          0
  10.36.8.0/21       Wired_Clt       3    connected            1          0
  10.36.16.0/21      SPC_IPADS       5    connected            1          0
  10.36.24.0/21      Sixthform_Wifi  6    connected            1          0
  127.0.0.0/8        reject               static               0          0
  127.0.0.1/32       lo0                  connected            1          0
  172.16.0.0/21      Guest           41   connected            1          0
  172.16.100.0/24    Internet_GW     12   connected            1          0
  172.16.101.0/24    Mgmt_AP         13   connected            1          0
0
Netman66Commented:
I wonder if routing to null for the loopback is causing some grief?
0
Craig BeckCommented:
Do you have something bridging VLAN1 and VLAN3?
0
ful56ukAuthor Commented:
I have even brick dhcp server moved the role to a new server. Same results. Working other vlans, vlan3 still no issuing Ip's

Must be the config on the core so I think I'll start there first and delete vlan 3 and create a new vlan see what happens
0
Don JohnstonInstructorCommented:
Did you try removing the ip igmp command?

And I'm just looking for anything out of the ordinary and I noticed:

ip route 172.16.0.0 255.255.255.0 172.16.0.1

Except the next-hop address is the vlan 41 address.

I know it's not related, but you may as well remove that static route from the config lest it cause confusion later.
0
ful56ukAuthor Commented:
No all it is

Pc-----core-----dhcp server
0
ful56ukAuthor Commented:
Hi

Not sure what the issue was but i bricked the config and started again. Everything is working.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
frankhelkCommented:
No comment has been added to this question in more than 21 days, so it is now classified as abandoned.

I have recommended this question be closed as follows:

Accept: ful56uk (https:#a40666704)

If you feel this question should be closed differently, post an objection and the moderators will review all objections and close it as they feel fit. If no one objects, this question will be closed automatically the way described above.

frankhelk
Experts-Exchange Cleanup Volunteer
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DHCP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.