Remote Desktop Mac OSX 10.10 Freezes

I have a hard time with RDP at one location.  This location has the fastest service comcast has but RDP keeps hanging.  At another location where I am at a very slow connection, probably in the 1.5Mbs range I do not have an issue.

I have tried pinging and tracrt to the router and modem and the speed is very fast.  There is a self hosted voip box and about 10 others.   Regular internet browsing and email works, but I RDP hangs a lot.  Could be related but there are a high rate of dropped calls on VOIP.  The VOIP is Zulty's.
LVL 55
Scott Fell, EE MVEDeveloper & EE ModeratorAsked:
Who is Participating?
 
serialbandCommented:
What ping times do you get to your RDP?

Run your ping test longer than 20 pings, try 300 ping  (about 5 minutes) and monitor your packets there.


Which RDP client are you using?   You may want to try a different one to see if it connects.

Remote Desktop Connection (older Microsoft client)
Microsoft Remote Desktop (newest Microsoft client from App Store)
CoRD
2x
0
 
serialbandCommented:
Check your comcast ping times and see if they're dropping packets or if there's a wide variance in Ping times.  Browsing and email don't need consistent ping times, but RDP and streaming does.  I've found that Comcast tends to have somewhat unsteady network speeds, while DSL and fiber has steadier speeds.

If your VOIP box is dropping calls too, that's a sign that you should have called Comcast to make sure the line to your wall jack is clean.
0
 
Scott Fell, EE MVEDeveloper & EE ModeratorAuthor Commented:
I have had comcast out twice and and they just replaced the modem just because they were out twice.  

But you may have a point. If the wiring from the switch to each wall port is bad, that could be an issue.

I did run a tracert and it goes fast locally through comcast but then just outside of the major city slows down.  I see the same thing in speed tests.  Within the state it is faster than out of state.
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
serialbandCommented:
Where is your RDP server?  Have you just tried to ping the IP address?  Watch the ping times while you ping.  Are you on Wifi or Wired?

The speedtest.net doesn't show dropped packets or occasional slow pings.  Run your ping for a few minutes each on different IP addresses.
0
 
Scott Fell, EE MVEDeveloper & EE ModeratorAuthor Commented:
One of the IP's that takes longer has ping times with a high fluctuation.


PING 68.86.84.210 (68.86.84.210): 56 data bytes
64 bytes from 68.86.84.210: icmp_seq=0 ttl=250 time=43.749 ms
64 bytes from 68.86.84.210: icmp_seq=1 ttl=250 time=34.576 ms
64 bytes from 68.86.84.210: icmp_seq=2 ttl=250 time=39.367 ms
64 bytes from 68.86.84.210: icmp_seq=3 ttl=250 time=50.751 ms
64 bytes from 68.86.84.210: icmp_seq=4 ttl=250 time=38.144 ms
64 bytes from 68.86.84.210: icmp_seq=5 ttl=250 time=34.710 ms
64 bytes from 68.86.84.210: icmp_seq=6 ttl=250 time=38.860 ms
64 bytes from 68.86.84.210: icmp_seq=7 ttl=250 time=37.741 ms
64 bytes from 68.86.84.210: icmp_seq=8 ttl=250 time=55.553 ms
64 bytes from 68.86.84.210: icmp_seq=9 ttl=250 time=56.736 ms
64 bytes from 68.86.84.210: icmp_seq=10 ttl=250 time=45.905 ms
64 bytes from 68.86.84.210: icmp_seq=11 ttl=250 time=43.643 ms
64 bytes from 68.86.84.210: icmp_seq=12 ttl=250 time=53.935 ms
64 bytes from 68.86.84.210: icmp_seq=13 ttl=250 time=40.058 ms
64 bytes from 68.86.84.210: icmp_seq=14 ttl=250 time=34.886 ms
64 bytes from 68.86.84.210: icmp_seq=15 ttl=250 time=50.987 ms
64 bytes from 68.86.84.210: icmp_seq=16 ttl=250 time=209.320 ms
64 bytes from 68.86.84.210: icmp_seq=17 ttl=250 time=40.802 ms
64 bytes from 68.86.84.210: icmp_seq=18 ttl=250 time=82.959 ms
64 bytes from 68.86.84.210: icmp_seq=19 ttl=250 time=128.288 ms

--- 68.86.84.210 ping statistics ---
20 packets transmitted, 20 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 34.576/58.049/209.320/40.561 ms
0
 
Scott Fell, EE MVEDeveloper & EE ModeratorAuthor Commented:
I was using the older ms client but also had the newer client that was just updated.  One thing I remembered hearing is you can't have both apps.  I don't know if that makes a difference but I did remove the old client.  

After pinging 300 times to the rdp, the min was 40ms, max 175ms and average was 53ms.  

I will test out using only the newest client on Monday.
0
 
serialbandCommented:
I'm not sure where you've heard that, but you can run both apps simultaneously.  I sometimes have all 4 clients running for tests, but I mainly use CoRD.  I use the newer MS RDP because some 2012 servers and Windows 8 RDP have additional security turned on.

I like CoRD because I can quick connect to the Login Window and see the Login Screen to know that my RDP connection is actually working, to easily isolate any connection problems from username and password.

If you don't have dropped connections, then you should check for reliable RDP with CoRD.  Maybe you're getting your RDP port blocked.  You can open up Network Utility, from /Application/Utilities/ and do a port scan on the RDP server from your Mac.  Enter port 3389 for the RDP port.

Some Caveats about Port Scans:
Don't do a full scan of all the ports, or you may be blocked by any possible automated firewall scripts.  You should only ever do full range port scan on IPs you own or control.  If you're port scanning IPs you don't own or control, your IP may be tagged and blocked by a firewall.  A scan on a single port scan should not trigger anything, unless you run a continuous scan.  This Network utility scanner just verifies that the RDP port is reachable by you with a single quick query. Your RDP client will normally connect with more packets.  You can do this to test open login connection that are supposed to be reachable by you.  It's like a ping test, but for ports.

Here's an example of a single port, single host scan and a return result you should expect to see:
I've used 10.0.0.50 as an example IP
Port Scan has started…

Port Scanning host: 10.0.0.50

	 Open TCP Port: 	3389   		ms-wbt-server
Port Scan has completed…

Open in new window

Here's an example of a scan that doesn't detect an open port.
Port Scan has started…

Port Scanning host: 10.0.0.50

Port Scan has completed…

Open in new window

0
 
Scott Fell, EE MVEDeveloper & EE ModeratorAuthor Commented:
Thanks!  I will give CoRD a try too.
0
 
Scott Fell, EE MVEDeveloper & EE ModeratorAuthor Commented:
I think I have figured it is the external network. When I ping'd 300 times in a row I could see a handful of response times that were 140ms to 200ms when most were in the 45range to 55ms range.  I am going to close this out for now because I think it must be a function of the comcast network in my area.  I have had comcast out a couple of times and all they do is a speed test using their speed test that has just a few servers per state probably because they are on their network and fast.  Now I have a 2nd tier person that is supposed to be monitoring  traffic for 48hrs.
0
 
FocISCommented:
Just out of curiosity, can you tell us the exact remote desktop client version you're using?  You can find this in the mac equivalent of Help > About

The older client version 2.1.1 is real sketchy when connecting to Win7 or Server 2008 R2 or 2012... there is a version that works perfectly but not officially released as far as i can tell, version 2.1.2

https://dl.dropbox.com/u/18309066/rdc_2.1.2_120917_release_enu_ship_clean_standard_retail_redlab_120917-apex-build-XS26-.dmg

source:
https://social.technet.microsoft.com/Forums/windowsserver/en-US/8e28b0af-b374-4ca0-a255-5fd854bdc7fa/rdc-for-mac-cannot-connect-to-ts-server-with-error-message-you-were-disconnected-from-the?forum=winserverTS
(search and find "4:06 PM" for the original post)
0
 
Scott Fell, EE MVEDeveloper & EE ModeratorAuthor Commented:
I appreciate that.  While I have heard that the newest version of ms rdp from the app store is the one to use, I have been using both the previous and newest version. I have recently removed the previous version and only using the newest version from the App Store. Version 8.0.14 (Build 25823)

The issue seems to be the network between the building and node in a major city where ping times can high.  As I think I stated on another ISP with 10% of the speed, I have no issue keeping the connection so this is not a software issue. I wish it was that easy.
0
 
serialbandCommented:
You can still connect with the older Remote Desktop if the RDP server is set to lower security on the newer Windows systems.  I use it to test for less secure access, which is why I keep it around.

Did you try the port scan?  Did that respond.
0
 
Scott Fell, EE MVEDeveloper & EE ModeratorAuthor Commented:
I'm not sure what to gain out of the port scan.  This is something that happens at one location/isp.  It's a dedicated web server and I can control the firewall/open ports.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.