Sharepoint 2013 - Search Box default text "Search..." doesn't disappear when you type in the box.

Hello, I'm currently working on a SharePoint 2013 site with a custom template and I'm having an issue with the search box. The search box has "Search..." by default in it and when you click in the box it doesn't remove that text. Therefore if you start to type in the box you have to delete the "Search..." text. Any idea how to fix this? Help? :)
LVL 1
vpetersenAsked:
Who is Participating?
 
Jamie McAllister MVPSharePoint ConsultantCommented:
Open the page in Internet Explorer, and press F12. Select the search box and look into the right hand pane to see what CSS might be being overridden.

If all else fails you may need to introduce some custom CSS or Javascript to the Masterpage to correct this.

This is how it's usually done and maybe this process is being interfered with;

http://stackoverflow.com/questions/108207/how-do-i-make-an-html-text-box-show-a-hint-when-empty
0
 
Mohit NairSenior AssociateCommented:
Go to master page gallery and open display templates > Search. You need to edit Control_SearchBox page. You can keep the prompt value to "" by editing Control_SearchBox.
For more information refer this
http://blogs.technet.com/b/tothesharepoint/archive/2013/09/19/how-to-change-the-text-that-is-displayed-in-the-search-box-web-part-in-sharepoint-server-2013.aspx
0
 
vpetersenAuthor Commented:
I am going to look at your responses, just haven't had time yet. Thank you!
0
 
vpetersenAuthor Commented:
You both were correct. It was a custom js file that had the Search... replacement text in it. I just changed it to "" as suggested, problem solved.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.