Poor Perfomance of WiFi: vWLC with Lightweight Access Point

I am replacing three autonomous access point (Single band 2.4Ghz/802.11n) with a vWLC (latest image) running on ESXi 5.5 with 3 Lightweight Access Points (Aironet 1702i - 802.11ac).

The vWLC  and Lightweight Access Points are connected on the same Layer 3 gigabit Core Switch where the  autonomous access point are connected.

While transferring a big file from a laptop (WNIC: Intel Dual Band Wireless-AC 7260) to a file server with the old autonomous access point I get speeds of 7MBps, but with these new Lightweight Access Points I get up to 3MBps.

The results will not vary even with the the vWLC default settings or tweaked settings.

The Data Port (Trunk-Tagged Port), Service Port (Access Mode Port) and Lightweight Access Points (Access Mode Port) are on different VLANs/Subnets.

I also tested with a laptop with a 3x3 WNIC (802.11AC) and only got speeds of up to 19MBPs (after working hours).

Any thoughts of what is causing this poor performance?

Thank you
turbomaxdrAsked:
Who is Participating?
 
Craig BeckCommented:
Sorry, DCA is what I wanted... it's been a long day!

You have a lot of co-channel interference from other APs.  Channel 6 looks like it would be the best way to go.

What channel is each AP using?  Wireless -> All APs -> 802.11b/g/n radios
0
 
Craig BeckCommented:
Are you sure your clients are connecting at 802.11ac speeds?  Check the WLAN NIC's status to see the connected rate.

Is it 19Mbps or 19MB/s??

19MB/s is roughly 350Mbps (give or take overheads) so that's not actually bad, but it doesn't tell me if you're connecting at 2.4GHz or 5GHz (although it's more likely to be 5GHz).  A screenshot of a connected client's stats from the vWLC would help determine this.
0
 
turbomaxdrAuthor Commented:
Hi Craigbeck,

Most of my clients are 2.4GHz N.

It is 19MB/s 5Ghz AC.

My actual concern is the 2.4Ghz N speed with the same laptop getting 7MB/s with the Autonomous N APs and 3MB/s with the new LAPs....when the file transfer starts is @700KB/s.

I will update this post on Monday with the screenshoot you are requesting.

Thank you!
0
How do you know if your security is working?

Protecting your business doesn’t have to mean sifting through endless alerts and notifications. With WatchGuard Total Security Suite, you can feel confident that your business is secure, meaning you can get back to the things that have been sitting on your to-do list.

 
Craig BeckCommented:
It may be nothing to do with the fact that the APs are Autonomous vs Lightweight.  The Lightweight APs operate in FlexConnect mode when attached to a vWLC.  Are your WLANs configured to use FlexConnect Local Switching (on the WLAN -> Advanced tab)?
0
 
turbomaxdrAuthor Commented:
Hi Craigbeck,

FlexConnect Local Switching (on the WLAN -> Advanced tab): Unchecked
I just enabled it, so will test on Monday.

I got this warning:
Enabling FlexConnect Local Switching will disable mDNS Snooping. Press OK to continue.

Is that alright?

Thank you
0
 
Craig BeckCommented:
Leave it as it was or clients won't be able to connect.

The problem may be that you're putting all traffic through a 1Gbps link at the vWLC.  Can you check the NIC performance for the VM in ESXi during the day when its slow?
0
 
turbomaxdrAuthor Commented:
It is slow during the day and after working hours.

I understand that with the Local Mode (FlexConnect Local Switching: Unchecked) all the traffic goes thru the vWLC, but I as mentioned above it is slow even when there are not users connected, but my laptop.
0
 
Craig BeckCommented:
You said it's better after hours than during the day but you still think it's slow.  I don't think it is slow.  Sure, it may not be as fast as it could be, but 19MB/s is over 150Mbps throughput.  That's not bad for a wireless client.

What I'm getting at is that it might be congestion at the NIC on the vWLC.  Checking throughput via vSphere will be easy enough.
0
 
turbomaxdrAuthor Commented:
Thank you for your prompt response Craigbeck

I understand you are pointing to a bottleneck on the vWLC Data port NIC, that makes a lot of sense.

Remember up to 19MB/s using AC after hours, during the day it will be up to 12MB/s.

But after working hours shouldn't it be faster than up to 3MB/s using 2.4Gz N? I would say it should be as fast as the Autonomous APs: 7MB/s?
0
 
Craig BeckCommented:
Remember up to 19MB/s using AC after hours, during the day it will be up to 12MB/s.
Again, probably contention.

But after working hours shouldn't it be faster than up to 3MB/s using 2.4Gz N? I would say it should be as fast as the Autonomous APs: 7MB/s?
Maybe it should.  I'd have to check the configs on each AP.
0
 
turbomaxdrAuthor Commented:
Completely understood.

For testing purposes of FlexConnect, would you recommend this:

Create a new WLAN (FlexWiFi), set it for FlexConnect Local Switching, and then on one of the LAP (Trunk port) set the FlexConnect/VLAN Mapping for this new WLAN?
0
 
Craig BeckCommented:
Yes, that would allow you to rule-out any congestion possibility at the vWLC.

Are your AP switchports already configured as trunks?  If yes, this will be a simple test to configure.  If not, just make sure you don't lose the APs when you reconfigure the switchports.
0
 
turbomaxdrAuthor Commented:
They all were set on Access ports, but I just set the port of the one as I mentioned above as Trunk with the Native Trunk set to the VLAN for LAP Management.

Let's see tomorrow how it works, but I think it should improve since we will be ruling out the congestion @vWLC as you suggested.

Excuse my ignorance, but is there any way to calculate the real max WiFi speed that can be reached? Taking into account the kind of environment, interference, overhead, etc.

Thank you
0
 
Craig BeckCommented:
Wireless throughout can roughly be calculated using...

Throughput in Mbps = (PHY rate / 2) - 10%

So, if the wireless link speed (PHY rate) is 300Mbps you'd do...

300 / 2 = 150
150 - 10% = 135Mbps

To get that in MB/s...

135 / 8 = 16.875MB/s


Of course, this is theoretical maximum (roughly).  Expect less.

Interference can have a detrimental effect too.  If all your APs are on the same channel and they can all 'see' each other that will make performance suffer as more clients connect.  This may be the issue too.  If you go to the Wireless tab on the vWLC and hit 802.11b/g/n under the Access Points section you'll be able to see what channel each AP is using.
0
 
turbomaxdrAuthor Commented:
Wow excellent explanation.
0
 
turbomaxdrAuthor Commented:
I might sound silly, but....

We divide PYH rate by 2, because WiFi is half-duplex regardless of the standard, including 802.11ac?
0
 
Craig BeckCommented:
That's exactly right.  All WiFi is half-duplex as long as transmit and receive happen on the same channel.
0
 
turbomaxdrAuthor Commented:
Hi Craigbeck,

No improvement in the speed after testing the new WLAN with FlexConnect.

Any idea what could be causing the slowness with these LAPs?
0
 
turbomaxdrAuthor Commented:
Any input on this?
0
 
Craig BeckCommented:
Sorry, I didn't get an email notification for the comment you posted yesterday.

Can you connect a client and post a screenshot of the client status from the vWLC?
0
 
turbomaxdrAuthor Commented:
Let me know if that's what you need
0
 
turbomaxdrAuthor Commented:
Attached:
Clients.png
0
 
Craig BeckCommented:
Thanks.  Now can you click on the MAC address of that client and post that too please?
0
 
turbomaxdrAuthor Commented:
I had to make multiple screenshots to cover all the info, please find them attached.
2015-03-17-19-19-35.png
2015-03-17-19-20-23.png
2015-03-17-19-21-47.png
2015-03-17-19-23-47.png
2015-03-17-19-24-18.png
0
 
Craig BeckCommented:
You don't have any of the 802.11n (MCS) data-rates enabled.

Follow this to enable 802.11n then test again (just to Step 6)...

http://www.cisco.com/c/en/us/td/docs/wireless/controller/7-4/configuration/guides/consolidated/b_cg74_CONSOLIDATED/b_cg74_CONSOLIDATED_chapter_0101.html#d59807e21a1635
0
 
turbomaxdrAuthor Commented:
Hi Craigbeck,

I might be wrong, but those data rates come enabled by default as expected, regardless of that I haven't touched them at all.

Please refer to the attached screenshots and txt files for details.

BTW, my vWLC build is 8.0.110
802.11a.txt
802.11b.txt
802.11n-b-g-n.png
FlexWiFi.png
QoS-WMM-Policy.png
0
 
Craig BeckCommented:
You are correct, they are enabled by default.  However, the client stats only show 802.11b/g data-rates.

Can you therefore check the client you posted the stats for?  I'd guess that the NIC's advanced settings aren't configured to use 802.11n.
0
 
Craig BeckCommented:
Actually... the client's connected data-rate is m7 so it is using 802.11n.
0
 
Craig BeckCommented:
Can you install Acrylic Wifi Free on that client and post a screenshot of what you see when it scans for a couple of minutes?

https://www.acrylicwifi.com/en/wlan-software/wlan-scanner-acrylic-wifi-free/
0
 
turbomaxdrAuthor Commented:
Hey Craigbeck,

Requested screenshots attached.
Signal-Strength.png
2.4Ghz-APs-Channels.png
0
 
Craig BeckCommented:
There's a lot of RF there, especially on Ch1.  I'd see if you get a better service by changing the channel on the AP you can see in the scan to Ch6.

The WLC should be doing this for you though.  What settings do you have on the Wireless -> 802.11b/g/n -> DFS settings?
0
 
turbomaxdrAuthor Commented:
I have tried Ch 6 before, however I will give it a shot once again.

There is no DFS, but DCA, screenshot attached.
DCA.png
0
 
turbomaxdrAuthor Commented:
There is a DFS under 802.11a/n/ac, the screenshot is attached.
DFS.png
0
 
turbomaxdrAuthor Commented:
After running a survey with Acrylic Wifi Free, I realized the vWLC was assigning the more channels congested  channels to the APs, so I proceed to assign the less congested channels as craibreck suggested, and that made the trick.

Thank you so much!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.