Samsung Galaxy S4 Smart Phone: "Not registered on Network"

Hi,

 I have Samsung Galaxy S4. I have been using for a year. Today, suddenly, I cannot call somebody (either to their cell phone or home phone).

The message that I get: “Not registered on Network”

However, I still can get the my Yahoo Email; I still can get the message from “WhatsApp” groups

Any help?

Thanks,
tjie
tjieAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Natty GregIn Theory (IT)Commented:
Do a battery pull on the device
0
tjieAuthor Commented:
I do a battery pull, but the problem remains

I contacted the T-mobile; Per T-Mobile, there was someone changing "the security setting" of my account. They brought it back as "default"; asked to restart my smart phone, and solved the problem.


tjie
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
tjieAuthor Commented:
The problem was solved by T-Mobile my provider
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Smartphones

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.