Processing lag time while editing in Lr and Ps

Recently, while editing images in Ps and Lr there has developed a processing lag time, like "buffering".  Sometimes I have to stop and wait for processes to catch up and it's driving me nuts!  I have a big shoot tomorrow so will have several hundred images to process on Monday.  I will not make a dent in the project with this kind of behavior!

I tried to get a driver upgrade but that link was "temporarily unavailable", I registered at the "Support Community" but it's for "Providers" and "Developers" and is no way a "support community".

Before posting this I had Qeeksquad run the usual gamut of utilities and they found nothing.  They updated some things and cleaned things up and told me the problem was fixed; it wasn't.

Graphics card
mikecox_Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

lherrouCommented:
mikecox,

What's your hard drive space look like? Are you using a separate HDD for your scratch disk than for your file storage? And how much RAM do you have (and how much shows available in System Utilities)?

My guess is that you are running out of working space somewhere, and Adobe is doing a juggling act to try to process your images with the space it has available. It could be some of your RAM has gone bad, or (more likely) you are just short on space on your scratch and/or working drive.

Best practice is to have a scratch drive separate from your working drive, and my recommendation is a minimum of 10 X the space needed for the number of images you have open at a time. So if you have 10GB of images open, you need 100GB of scratch disk space.

Cheers,
LHerrou

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mikecox_Author Commented:
You may be right, it makes sense.  My RAM is topped out at 10Gb.  I have a SSD in my ASUS ZENBOOK UX32VD, which is partitioned in a strangely  unconventional way...by the manufacturer.  I can't explain it, I just know the volume for the partition can't be adjusted in the conventional way.  The primary partition has 10 GB of available space, the secondary partition has 86GB. The computer has an Intel i7 processor.

Lr doesn't have a scratch drive, but it does have cache, which I set to the secondary drive; thinking it would be faster on the SSD rather than use my external HDD.

I have, recently, been importing my images to the secondary drive, thinking they would process faster there.  I used to import them to my external HHD.  Could that, having the images and the cache on the same drive, cause these problems?

Ps shows 8888MB of available RAM; which I think would r/o bad memory, since it's all being seen here; right? And I set Ps to be allowed to use 70% of it.  Would that cause problems when I have both Lr and Ps open?  Is Ps hogging memory that Lr can't use because of this setting?  Under the performance tab I have the graphics set to "Advanced".

My scratch is set to 85GB and is assigned to my secondary drive; where my pictures are now being imported to.  There are three scratch drives listed C: and L:, but not checked.  

I think I will try and move my images back to my ext HDD and see if that improves anything.
lherrouCommented:
Yes, if you've changed your work flow, try going back and seeing if the old workflow still functions as it should, as your first step.

What version of PS and LR are you using? And 64 or 32 bit? And if your PS scratch disk is set to 85GB and is assigned to your secondary drive, which is also the cache disk for LR, and there's only 86GB available... I would look at dropping that down or assigning it some other way. I'm also wondering about that 10 GB on the primary drive. If you are getting some kind of paging file written there...
mikecox_Author Commented:
Things seem to be running better; which I can't really explain, because I haven't done anything /-:

I'm using PsCC and the current v of Lr on win8 and I'm using the 64bit versions.

It sounds like I should just avoid running Lr and Ps at the same time.

You referred to 10GB on the primary drive. I'm worried about that too because I'm running out of room and Asus did something strange when they partitioned the drive.  I tried to remove the partition but the tech said it couldn't be done and referred to Asus's setup.
 
But that's another question!
mikecox_Author Commented:
proved a lot of options to consider.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Photos / Graphics Software

From novice to tech pro — start learning today.