PXE - WDS Service - SCCM 2012

On Friday morning and on Sunday morning this week the Windows Deployment Services service on both our SCCM servers that service PXE requests broke and stopped responding correctly to PXE requests, and also started consuming significant amounts of CPU resources on the server.  
This state led to machines not receiving PXE requests when rebooted (workstations configured to NETWORK boot as first boot option), causing some machines to stall at boot,
Stalled machines rebooted while the services were broken would most likely stall again.

In both cases, restarting the WDS services while in this state restored proper service.   However, I am concerned that this behaviour is going to continue to occur. Any ideas what could be causing this? This was working fine for about 2-4 months, no patches applied in last week, we running version 6.3.9600.16384 for WDS,
Any ideas will be most appreciated
Thanks in advance,
Craig PaulsenSystems EngineerAsked:
Who is Participating?
 
Randy DownsOWNERCommented:
Maybe this thread will help. They were upgrading to R2 but maybe the fixes still apply.

the steps I took (almost with a restart with each step)
Uninstalled ADK 8.1
Removed boot images from Distribution points
Removed Boot Images from SCCM
Unchecked PXE deployment from Server and Site System Roles (Let SCCM uninstall WDS)
Removed RemoteInstall Directory
Re-downloaded and installed ADK 8.1
Turn on PXE deployment - check Distmgr.log file to see when it finishes
Add Boot Image from ADK to SCCM. Turned on the PXE deployment for these images
Distributed Boot Images
The last step is where WDS has stopped working in the past, but today the WDS service stayed up and I was able to deploy one of my Windows 7 task sequences successfully.

Fix:
Uncheck "deploy this boot image from the pxe-enabled dist point" on each boot image
Uncheck PXE
Check distmgr.log for uninstall success
Reboot (before the reboot the wds service will be started) DONT SKIP THIS REBOOT OR IT WILL FAIL
After reboot wds service will be gone
Add wds, choose auto reboot
Wait for wds to complete installation after reboot
Check to make sure wds is set to manual and not started
Rename or delete remoteinstall folder
Check pxe box on the DP
Check distmgr.log (filter to 'contains' wds) for success
WDS service should be started and automatic
Add new 8.1 boot images using copype.cmd process.
Uncheck "deploy this boot image from the pxe-enabled dist point" on each OLD boot image
Check "deploy this boot image from the pxe-enabled dist point" on each NEW boot image
Distribute NEW boot images
Wait for NEW boot images to be distributed
RemoteInstall\SMSImages should contain 2 boot images
Test PXE
0
 
Craig PaulsenSystems EngineerAuthor Commented:
ANYBODY?
0
 
Craig PaulsenSystems EngineerAuthor Commented:
thanks for your response, we've found the issue to be with the WDS service on the x 2 DP's, the service appears to have been in a hung state as a result of the reboot storm (IE: workstations configured via a GPO to reboot at 3am on a Sunday morning)
Restarting the service resolved the issue.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.