MS coded UI Test Build is keep generating code...

Hi,

I don't have any thiswith WPF nor winform when I generated coded UI codes.
However, when I try to 'Add and Generate' with a method name after record, it doesn't save and keeps runnig.
any idea what's going on?
7.JPG
IzzyTwinklyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Bob LearnedCommented:
Sounds like a bug--what version of Visual Studio are you using?
0
IzzyTwinklyAuthor Commented:
Hi Bob,
I am using Visual Studio 2013 Ultimate version. :(
0
Bob LearnedCommented:
I have 2013 Ultimate Update 4.  What type of project are you recording tests for?
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

IzzyTwinklyAuthor Commented:
I opened web application from VS 2013.
so it gave me the web site like the following.
17.JPGI just select the values from dropdown list and click the button,
That's all I did.
and i think that my visual studio is also update 4 since when I opened 'About Microsoft Visual Studio' popup, it says Update 4 after Version info.

Thanks!
0
Bob LearnedCommented:
I have the same issue when recording a web page.

I am going to try this:

https://social.msdn.microsoft.com/Forums/windows/en-US/41f5a5d1-3754-4721-956f-984a7596eafc/codedui-test-builder-freezes-on-pause-or-generate-code?forum=vstest

I tried running in safe mode, but it gave errors in my VS Test Explorer window.
I repaired VS 2013 and, CodedUI now works!
0
Bob LearnedCommented:
Repairing Visual Studio didn't help.  I was recording with Chrome browser, and it still didn't work.  When I switched to Internet Explorer, it would stop recording, and I could generate code.

What browser are you using?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
IzzyTwinklyAuthor Commented:
Hi Bob,

Thanks for all your help.
I was using Chrome. Can we do anything about it?
Does MS know about this? I think that Coded UI should be used with mostly IE I guess?
0
Bob LearnedCommented:
If we know anything about Micro$oft, then we should answer that question as a definite "YES!!", that you should use Internet Explorer with Coded UI.  

I have no idea about whether MIcro$oft knows about this, but there is always Connect.

https://connect.microsoft.com/
0
IzzyTwinklyAuthor Commented:
It's very sad that Coded UI doesn't work well on other browsers.
0
IzzyTwinklyAuthor Commented:
I forgot to say thank you.
Thanks for all you help Bob! =)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Quality Assurance

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.