Mailbox Resource Calendar

Hello experts, hope you had a wonderful weekend and that you can help with this issue. Running Exchange Server 2010 on Server 2008 R2. We just started deploying Mailbox Resource Calendars. Created them all at the same time, Seven of them. All Calendars show Details except for one that shows "Busy". Only one user can see Details on the Calendar that is showing Busy for everybody else. Any preliminary ideas? Your help is greatly appreciated.
eplestinoAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

imkotteesSenior Messaging EngineerCommented:
Hi,

Check the calendar permission for default users and change it according to your free/busy need
0
eplestinoAuthor Commented:
imkottees, thank you for your reply. I just want to make sure we are on the same page with this issue.

These are mailbox resource calendars for meeting rooms. To follow your suggestion, where should I go to get to the Calendar Permissions to check on the default users and change it?

I apologize if I am not following as expected but I couldn't find the option.

Thanks again.
0
eplestinoAuthor Commented:
Following up on my own posting. I have requested Attention but no answer either.

If somebody can help me here, it would be greatly appreciated.

If more information is needed, I will be happy to provide it.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Hypercat (Deb)Commented:
In the properties of the mailbox in the EMC, go to the Resource In-Policy Requests tab and make sure that you've selected either "All Users" or included everyone in the "Selected recipients" box at the top under "Specify users who are allowed to submit in-policy meeting requests..."
0
Hypercat (Deb)Commented:
Also, you do have to edit the default access level for the mailbox.  Here's the command for the EMS:

Set-MailboxFolderPermission [meetingroom]:\Calendar -User Default -AccessRights Reviewer
0
eplestinoAuthor Commented:
hypercat, thank you for the follow up. I am including an attachment with permissions  from the Get-MailboxFolderPermission script (brand new to Exchange PowerShell. Just following some postings from somewhere else. I hope this helps you to get a better idea of what I have. This is a production server and need to be very careful. Do I still follow up on your two steps.

Thanks,
Get-MailboxFolderPermission-Snip.JPG
0
eplestinoAuthor Commented:
Here is the snip for the Resource In-Policy Requests.

Thanks,
0
Hypercat (Deb)Commented:
The result from the Get-MailboxFolderPermission shows that the default permissions are read only.  You have allowed specific users to have Reviewer permissions. In order for all users to be able to see the Free/Busy info, set the default to "reviewer," as show in the powershell command. I recognize your caution due to the fact that this is a production server, but changing these permissions is not going to have any deleterious affect.

Your second post doesn't have an attachment if it was supposed to.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
eplestinoAuthor Commented:
hypercat, sorry about not including the snip the first time around (it happens more often than I would like to accept!)

Thanks!
Get-MailboxFolderPermission-Snip-01.JPG
0
eplestinoAuthor Commented:
OK, here we go. I had them totally mixed up.
Get-MailboxFolderPermission-Snip-2.JPG
0
Hypercat (Deb)Commented:
Ok - the in-policy settings on the mailbox properties look fine.  Again, I think the problem is the default permissions on the Calendar folder in the mailbox. Please change the default permissions to Reviewer and see if that resolves your issue.
0
eplestinoAuthor Commented:
hypercat, I ran the Set-MailboxFolderPermissions command and that did it.

Thanks a bunch again for your help, you were awesome!

Cheers,
Ernesto.
0
eplestinoAuthor Commented:
hypercat, I ran the Set-MailboxFolderPermissions command and that did it.

hypercat rocks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.