Black screen in remote server using Remote Desktop.

Hi Experts,

I'm trying to connect to a server using remote desktop and I see a black screen, is there any way to get out of this?

See attached.
untitled.bmp
LVL 5
bfuchsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Matthew KellyCommented:
Try using Ctrl + Alt + End to bring up the task manager in the remote desktop server to see if there is an app running full screen or something else that is causing the issue. This will hopefully solve your short term problem.

Long term, there is also an Microsoft Support article on it being caused by Bitmap Caching:
http://support.microsoft.com/en-us/kb/555840
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bfuchsAuthor Commented:
Hi,

Now I'm unable to connect altogether, see attached.
Also got a message that this user cannot connect, however try log in as another user..
tried that key combination but didn't respond.
untitled.bmp
0
Zacharia KurianAdministrator- Data Center & NetworkCommented:
When you try to log in twice with the same account, you get the error that " couldn't connect in this amountof time allotted".

Now to your actual issue;

1. Restart the remote computer from the local console (if you can physically access the server)
2. Disable BitMap Caching in your RDP client (on the EXPERIENCE tab) and try log in again.
0
SandeepSr System AdministratorCommented:
Normally such scenarios come when there are below issues

1) Low disk space on drive C
2) Server is in hung state or there is high CPU/Memory utilization by some process.
3) Server is UP and Running from many days like more than a year or so which block memory and cause such things.

To see what processes are utilizing maximum CPU or Memory on the server, you can make use of PSTools.

Pslist help us to identify such processes from remote computer, and pskill will help you to kill such processes remotely.

https://technet.microsoft.com/en-in/sysinternals/bb896682.aspx

If this one do not work, then you can try rebooting the server.

If you can afford a reboot, simply try this one. Assuming you got account which is Local Admin on the remote server as well.

shutdown /r /f /m \\ServerName

This one will reboot the server remotely. If this one fails due to high CPU or Memory utilization, you have to get it rebooted with help of Local Console.
0
bfuchsAuthor Commented:
Hi Experts,

In the end I logged in today as administrator and logged off that user, that solved for now the problem.
I guess if something like that happens in the future I will follow what you suggested.
Perhaps if someone knows of a way I can track back what caused, that is something I would make use momentarily.
Thanks to all participants.

Thanks,
Ben
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.