Install .NET 3.5 onto aServer 2012 New Build Fails

I have just built a new MIS server which has Server 2012 installed and no other features. By default .NET 4.5 feature is installed and enabled. I have just installed SQL 2012 and need to enable/install SQL Server Management Tools but I'm getting an error saying that .NET 3.5 needs to be installed first.

I have tried installing .NET 3.5, and uninstall 4.5 to allow 3.5 on but recommendations strongly say not to uninstall .NET 4.5.

All I need to do is 'Add' the 'Management Tools - Basic & Complete' via the SQL Server 2012 Setup

When I try and Add .NET 3.5 via 'Add Roles and Features Wizard' I get the following message:
""Installation of one or more roles, role services, or features failed.
The source files could not be found. Try installing the roles, role services, or features again in a
new Add Roles and Features Wizard session...........

And I can't disable .NET 4.5 as the check boxes are greyed out.

Any advice helpful
LVL 2
CTCRMInfrastructure EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Cliff GaliherCommented:
Do *not* disable 4.5! They can coexist. There is no reason to try disabling 4.5.

As far as 3.5 goes, this is a common problem because of a new feature in 2012 where features are no longer stored in the winSxS folder, and are only installed "on demand." If the server has unimpeded access to windows update (is on the internet, no firewall blocks, not configured for WSUS) then windows will download and install 3.5. Usually.

But many environments block, throttle, or otherwise manage latches anther way, so this fails. In the add features wizard is a checkbox to specify feature location. You can point it to the original installation media and that will usually work.

If you are very unlucky, you have installed patches so that the machine doesn't match anything on windows update and no longer matches the original install media. If that's you, things will hurt. You can uninstall windows patches on your server (risky) or you can inject them into your install media using disk...which means copying .wim files, having them accessible and editable, and downloading each patch from your installed patches and injecting them.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CTCRMInfrastructure EngineerAuthor Commented:
Damn, can't believe it, I have already unchecked .NET 4.5 and when RDP'ing back onto the server it seems to authenticate but I now just have a blank desktop with no icons nor taskbar etc. How do I get round this?

With regards to SSMS tools, via Powershell I tried to enable the feature pointing locally to c:\sources\sxs and also used the /All switch but was presented with an error saying that the source filed could not be found. As the source files were packaged into an ISO I extracted a copy of the Sources\sxs directory and pasted locally on the server (C:\) but still getting the same error in Powershell and the same error when Adding Roles & Features UI.
0
Cliff GaliherCommented:
I'd plan on reinstalling the server at this point. Sounds like you've done enough tinkering to break things in a very unsupported way. Reinstall. Enable 3.5 using the original media as a source. Then patch and install desired applications. Since you "just built" this server (from your original post) this will be faster than attempting a repair which may not even be complete. And remember, don't disable 4.5 next time.
0
Seth SimmonsSr. Systems AdministratorCommented:
i agree; start over and install all the features and roles you will need before patching
there have been many posts from folks having issues with .net 3.5 on 2012 because of either updates installed first that end  up breaking the component or something else already installed
0
CTCRMInfrastructure EngineerAuthor Commented:
Guys, The reason for me getting the errors when trying to locate the sources\sxs is because I was pointing to a non R2 setup disk so looking wrong files in the wrong location.
All fixed now and SQL2012 is functional on Server 2012, time to hand it over.....
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2012

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.