Accessing data on Raid Member

Say, I've got 2 drives from a software Raid - Bios controlled installed as LVM partitions.
I've brocken the RAid drives and using Knoppix I've inserted a single disk.
If I run LVM commands - tells me no Volumes found.

fdisk -l shows me
sda1- this is the boot partition and mounted
sda2 Linux Extended (The data I want to browse)

When attempting to mount get error:
mount: unknown filesystem type 'promise_fasttrack_raid_member'

Please help.... !
shaunwinginAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

SandyCommented:
#mdadm --examine /dev/sda2

needed to create md virtual device using mdadm:

#mdadm -A -R /dev/md9 /dev/sda2

So it could be mounted without hassle:

#sudo mount /dev/md9 /mnt/old_hdd/

#mount | grep ^/dev/md9

try this and keep us posted here.

TY/SA
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
shaunwinginAuthor Commented:
mdadm is for Linux Raid - this is a softraid in the Bios and surely mdadm not applicable!
0
SandyCommented:
Give us more details regarding your softraid
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

arnoldCommented:
Pvscan, vgscan, lvscan
Are you trying to access the data  on a different system?
Or on the same one from which you separated the drive?
Pvdisplay, vgdisplay, lvdisplay to see whether the LVM data on the drive is seen, but not have been activated.

How did you break the mirror? While the system was running, labeled the disk as failed, and ready to be replaced, and pulled it?
Powered off system and during reboot, reversed the setup of raid process?  
Just to be sure, that was a RAID1 setup?
0
shaunwinginAuthor Commented:
Same system, but changed Bios mode from Raid to simple mode.
Broke mirror while system was off.
Yes a Raid system 1
0
arnoldCommented:
The SATA raid while using "LV" might not be one similar/supported by linux.

Does pvscan/vgscan/lvscan and pvdisplay, vgdisplay and lvdisplay lvdiskscan do they reflect any LVM data?

Have not used or tried to access this type of drive setup so not sure.
0
arnoldCommented:
Is this a test you are running just in the event of, or you really need the data?

If you can access the sda1, what OS was on the system? the issue could be related to what you were using on the system which Distro?
Presumably the SATA raid from the HP was for the entire drive and was presented as an unformatted single volume to the OS you installed.
0
shaunwinginAuthor Commented:
I need one directory - the mysql directory.
CentOS 6
0
shaunwinginAuthor Commented:
Drive comes up as unformatted - but data must be there - any programme that will let me browse it?
0
Joseph GanSystem AdminCommented:
0
arnoldCommented:
What happened to the system in which the drive was present? Did you reformat that? Does that system still boot? Seems you have a similar question going already.
0
Joseph GanSystem AdminCommented:
I have seen the same question you have asked three times here. You haven't give in details of what was happened. You had HP hardware RAID 1 on two disks, on top that you had LVM. You said you broken the hardware RAID, but before that you had scrowed up the LVM as well. Now you tried to boot from a Live CD, and you hope that you can get the data back.

First of all, you need to repaire the HP hardware RAID, which you couldn't use Linux Live CD to do this!
You need HP uitility to rebuild the hardware RAID, which will restory the data on it.
Even you had repaired the RAID, Linux Live CD did not have LVM information metadata, even the "data" is on the disk, Linux did not know how to read it!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Disaster Recovery

From novice to tech pro — start learning today.