Solaris 8 ufs restore

I installed solaris 8 on a ultra5 workstation, I then used ufsdump to dump all the partitions onto a network drive. Next I wrote a script to partition a new drive then restore the the ufsdump's onto the new drive. Next I used the solaris 8 02/04 install disk with the "boot cdrom -s" command. once at the prompt I setup the network and mounted the nfs share containing the ufsdump's to "/a". I then ran the script then rebooted with "reboot -- -r" and the system comes up with no errors. I then used the new system with no notable errors.

Next I created a solaris 8 jumpstart disk which boots up and runs a script to mount the network share to "/a" then runs the same script as above to partition and restore the disk. This time when the system reboots I get the following message after boot.
"tester  ufs_log: WARNING: ufs log for /mnt changed state to Error
"tester ufs_log: WARNING Please umount (1M) /mnt and run fsck(1M)"

The system seems to work ok but I keep getting this message. It seems that it is the cdrom causing the warning because if I leave the cdrom out of the drive the error goes away. But as soon as I put the cd back in I get the warning. I also tried booting into single user mode and running fsck on all the drives.

One thing to note is that I tried the same procedure using but installing solaris 2.5.1 then creating ufsdumps of that install and restoring it using the same script and it does not have the error.
reyes136Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Joseph GanSystem AdminCommented:
Sounds to me it might be a bug in Solaris 8. However, couldn't recall what patch was. As it is out of support.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
reyes136Author Commented:
Thanks for the help from many google searches I found the issue. I'm creating the jumpdisk on a solaris 10 which enables ufs logging by default on all mounts. Part of the procedure to create the jumpdisk requires me to mount  the /dev/lofi/1 , in order to add some files. When I did this it enable ufs logging on the cd partition so when ever I had that cd in It gave the error. The fix was to disable ufs logging when it was mounted.

"mount -o nologging /dev/lofi/1 /mnt"

This fixed the issue but I guess the issue was only when I inserted that specific boot cd. Once I made the change during creation of the jumpstart disk I no longer had the Warning.

Thanks for your help. I'm going to accept your response as accepted solution because my last question did not even get a response and was deleted.
Joseph GanSystem AdminCommented:
Nice work.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.