How to configure Server 2012 R2 for Remote Desktop

I am setting up Server 2012.
I want to access the server using Remote Desktop for Administrative purposes only.
I need to know what the minimum roles and services are that I need to install.
I assume I need "Remote Desktop Services"
I'm not sure about the following services:
   Remote Desktop Connection Broker
   Remote Desktop Gateway
   Remote Desktop Licensing
   Remote Desktop Session Host
   Remote Desktop Virtualization Host
   Remote Desktop Web Access

If I select Remote Desktop Gateway then it also wants to install Web Serber (IIS). I'm not sure I want to do this.

Any guidance will be greatly appreciated.
LVL 13
akbAsked:
Who is Participating?
 
Cliff GaliherCommented:
Firewall. In server manager, on local server screen, choose to allow remote desktop connections. Otherwise RDP is blocked. This is in keeping with MS's stance on shipping secure by design.
0
 
arnoldCommented:
See whether an option to manage remote access in 202 exists as it is on 2008, properties computer, advanced setting, remote tab or remote settings.

The roles you listed are for licensed multi-user access RDS/TS.
0
 
David Johnson, CD, MVPOwnerCommented:
you don't need to install anything for remote desktop for administration.  No additional licensing just add the user to the remote desktop users group
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
akbAuthor Commented:
Thanks Arnold. Your comment about "multi-user access RDS/TS" makes sense.

David, I expected it to be as simple as that. The problem I have is that when I try to connect to the server I get an error. That made me think I must need to configure something else.

The error I'm Getting is in the attachment.

I can ping the server. The PC is registered on the domain.
Clipboard01.jpg
0
 
akbAuthor Commented:
Thanks Cliff.
That made so much sense but I enabled Remote Desktop in the firewall for TCP and UDP and I'm still getting the same error.
0
 
Cliff GaliherCommented:
Don't just enable it in the firewall. Use server as I mentioned. Otherwise things get easily overlooked. They put that option in server manager for a reason.
0
 
akbAuthor Commented:
Thanks Cliff. I read "Firewall" and went that way. Now that I have followed your instructions properly it is working!
Thanks.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.