Cant get seagate 4TB Drive to initialize "incorrect function" error

I have tried Diskpart, tried Partition manager, partition magic.  I have 2 4TB Drives.  

They show up under disk management as "notinitialized"  However if I right click on Disk 1, the option to "initialize" is greyed out.  I do get a request anytime I open disk managment to initialize the disks, adn I choose GPT (both give this error though).  Once I click ok, I get Title: "Virtual Disk Manager" Text: "Incorrect function"  

This is on a Lenovo thinkstation D20

Not sure what else to do.
LVL 7
KnightsmanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
Which os is in use?
0
Natty GregIn Theory (IT)Commented:
put the disk in a caddy and try to format from there
0
Shahnawaz AhmedTechnical Services SpecialistCommented:
Can tou try to stop and start virtual disk service from services.msc? You might get an Incorrect function error too. Look the task manager's process tab and try to kill virtual disk service from there then it would show stopped then you need to start the service from services.msc
open disk manager right click on the disk and bring it offline. Then again bring online then try to initiakized.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

KnightsmanAuthor Commented:
Windows 7 Pro.

I thought about a caddy, but its at a remote site.  was installed but not finalized onsite.  Cant get out there until tomorrow, but even then im still concerned its not going to work properly.
0
KnightsmanAuthor Commented:
When stopping it, I get "windows could not stop the virtual disk services on local computer.
I get an Error 1067: the process terminated unexpectedly
0
KnightsmanAuthor Commented:
it did stop the services, and I restarted the services as you instructed, same results.
0
arnoldCommented:
Which windows 7 32 or 64? Updates? Sp?
Diskpar
 Are the drives combined/striped using MB SATA rAId?
0
arnoldCommented:
Try using the seagate disk tools to initialize the drive.
0
szichenCommented:
Delete any partitions on it, convert to GPT and try to initialize it.
0
Gerald ConnollyCommented:
Does your system support 4TB drives?

Have these drives ever worked in this machine?

It doesn't look like this machine has a UEFI BIOS so you won't be able to boot off a 4TB disk
0
noxchoGlobal Support CoordinatorCommented:
I would first try these drives on other machine and if they work there then you have a problem with this specific computer only. Either drives of such size are not supported or the motherboards BIOS should be updated.
0
KnightsmanAuthor Commented:
Win 7 Pro 64 Thinkstation D20
I've verified it will not work with GPT partitions, but It will work with splitting them into two, which is fine.  

Cant delete partitions, none have been created.  

When I try to  initialize with MBR, it still gives me the incorrect function error.

I would update the bios, but the only update to it, is for the CPU.  Not worth the chance of failure if the update isnt related.

I've checked drivers, all are updated.
0
noxchoGlobal Support CoordinatorCommented:
Do the drives fail on one machine only? Or is the problem for other machines as well?
0
Seth SimmonsSr. Systems AdministratorCommented:
agree with what was mentioned about hardware support
in looking at the specifications for that model, it shows it came with vista so that dates it
doesn't support gpt because there is no uefi support
i would get a smaller size; you can't split it because it still needs to be GPT to access more than 2tb
otherwise, as MBR, you can only use the first 2tb
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
KnightsmanAuthor Commented:
Its been a while, but wanted to update.  The Raid controller doesnt support anything over 2TB.  Moved the drives to sata ports on the MB, and worked fine.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.