Send Mail to Remote Domain always as Text

Despite the method used (client, OWA, whatever) I need to set Exchange 2013 to send mail to a specific domain, always as text (not HTML, not RTF, not whatever - only text). I can't find the way to set it. Please help. Thanks.
LVL 20
strivoliAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Guy LidbetterCommented:
Hi Strivoli,

You need to use message encoding options to enforce this. You can enforce this for a specific remote domain...

https://technet.microsoft.com/en-us/library/bb310794(v=exchg.150).aspx

Regards

Guy
0
Guy LidbetterCommented:
More specifically...

Have a google of this command

Set-RemoteDomain Contoso -ByteEncoderTypeFor7BitCharsets UseBase64

Open in new window

0
strivoliAuthor Commented:
If I run the command I get:

The operation couldn't be performed because object 'Contoso' couldn't be found on 'SRV-A001.domain.com'.
    + CategoryInfo          : NotSpecified: (:) [Set-RemoteDomain], ManagementObjectNotFoundException
    + FullyQualifiedErrorId : [Server=SRV-A006,RequestId=dfa42209-bf87-4621-8acf-b7279dbcfa75,TimeStamp=18/03/2015 10:
   54:23] [FailureCategory=Cmdlet-ManagementObjectNotFoundException] EA8BD0C8,Microsoft.Exchange.Management.SystemCon
  figurationTasks.SetRemoteDomain
    + PSComputerName        : srv-a006.domain.com
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Guy LidbetterCommented:
Contoso is a standard microsoft example domain name... you need to replace it with the domain you need to send the plain text mail to...
0
strivoliAuthor Commented:
I know Contoso :-) It's used by MS since the 80's :-))

Anyway... Contoso, gmail or gmail.com... I'll always get the same error back. As a result there's something else missing.
0
Guy LidbetterCommented:
I've been doing some looking into this... the solution to the error above is to create the remote domain first which I neglected to mention.

New-RemoteDomain -DomainName Contoso.com -Name Contoso

Open in new window


But irrespective of this, apparently an outlook client will always override the remote domain settings... which  I think is kinda rubbish.

I believed the solution would then be to set the content type of the remote domain to MimeText, disable TNEF and set the ByteEncoder to use 7bit, but in testing I couldn't get this to work. There are articles stating this then only works from OWA and not Outlook...

I'm digging a bit further now.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Guy LidbetterCommented:
p.s... I've had 2 people actually  typing in contoso recently... so, sorry for putting you in that bag of tricks too...
0
Hello WorldCommented:
Hi,

Please run below command to get details about remote domain:
Get-RemoteDomain | FL Identity,ByteEncoderTypeFor7BitCharsets

For your question, I want to double confirm whether all external mail flow experience this question.
It it only occur for special domain, this issue may be caused by the configuration of destination domain, then you can contact this domain's administrator to double check.

Thanks,
0
strivoliAuthor Commented:
Hi Guy, thanks for helping. I was missing the...

New-RemoteDomain -DomainName Contoso.com -Name Contoso

After running the above command, I could run the command...

Set-RemoteDomain Contoso -ContentType MimeText

Now, every mail sent to the Contoso.com domain is sent as Text.

By the way... I wouldn't work for Contoso... too much mail to manage :-)
0
strivoliAuthor Commented:
Guy gave me the required command. Thanks.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.