Cannot Remote Desktop or access share by IP Address, but can by computer name

Running Active Directory. One DC is Windows Server 2003, another is Windows Server 2008. I can ping and nslookup any computer by both name and IP address, and get correct results. Windows 7 PCs

I can Remote Desktop using PC name and AD credentials. Remote desktop fails when using IP Address. It keeps saying that the credentials are not valid. Same scenario for accessing c$. \\PCNAME\c$ works. \\IPADDRESS\c$ fails, asking for username and password, even though I'm using the same credentials that work via PCName.

I have tried adding a reverse lookup entry in DNS, tried adding WINS entry, and tried to leave then re-join the domain. Some PCs are having this issue, while others are not. I've looked for dis-similar things, and cannot find anything. Windows firewall is OFF. TCP/IP(v4) using static IP addresses. No duplicates in the network.

I can understand if it was the opposite...where I could log in by IP but not by name. But going in by name works fine, it's by IP that's the problem. The reason this is needed is because VPN actually logs in to different subnet and domain...so remote via IP is the only way that I know of around it.
jeffh2345Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NVITEnd-user supportCommented:

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jeffh2345Author Commented:
I found 3002657 and 3046049 on the server, but only found 3046049 on one of the affected workstations. Uninstalled what I found, and rebooted both. Still not working.
jeffh2345Author Commented:
After looking further, I did find the other KB, removed it, and it worked...THANKS!!
NVITEnd-user supportCommented:
Awesome. I'm happy it works. Have a nice day
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Remote Access

From novice to tech pro — start learning today.