get a apache 500 error and redirects to domain.com/public after changing SSL cipher

Hi,

I tried to update or change the SSL cipher in my WHM. But after the update my main home pages are being redirected to the wrong url. The home pages and other pages now are no longer working. But sub-directories are working. For instance, when I go to:
http://myultratrust.com it forwards me to:

myultratrust.com/public

And testthis.myultratrust.com forwards me to
http://testthis.myultratrust.com/public

It shouldn't be doing that. Don't know what WHM does in the back but it shouldn't be messing around with the folders of a site because of an SSL configuration change. I tried to change things back but WHM doesn't fix it back to the original state. I'm disliking WHM more because I have no idea what it does in the background. :(

This page properly gets forwarded though:

https://secure.myultratrust.com/ to
https://secure.myultratrust.com/diy/login/login.php

And this site works properly still:
http://emailmarketingservicesco.com/ (it's supposed to be a blank page)

I checked in my httpd.conf settings and I have this:

<VirtualHost 173.201.47.54:80>
    ServerName myultratrust.com
    ServerAlias 47.201.173.in-addr.arpa www.47.201.173.in-addr.arpa www.myultratrust.com
    DocumentRoot /home/myultrat/public_html
    ServerAdmin webmaster@myultratrust.com
    UseCanonicalName Off
    CustomLog /usr/local/apache/domlogs/myultratrust.com combined
    CustomLog /usr/local/apache/domlogs/myultratrust.com-bytes_log "%{%s}t %I .\n%{%s}t %O ."
    ## User myultrat # Needed for Cpanel::ApacheConf
    UserDir enabled myultrat
    <IfModule mod_suphp.c>
        suPHP_UserGroup myultrat myultrat
    </IfModule>
    <IfModule !mod_disable_suexec.c>
        <IfModule !mod_ruid2.c>
            SuexecUserGroup myultrat myultrat
        </IfModule>
    </IfModule>
    <IfModule mod_ruid2.c>
        RMode config
        RUidGid myultrat myultrat
    </IfModule>
    <IfModule itk.c>
 # For more information on MPM ITK, please read:
        #   http://mpm-itk.sesse.net/
        AssignUserID myultrat myultrat
    </IfModule>
    ScriptAlias /cgi-bin/ /home/myultrat/public_html/cgi-bin/

    Include "/usr/local/apache/conf/userdata/std/2_2/myultrat/*.conf"

</VirtualHost>

Open in new window


I don't see anything wrong with that config. Anyone know what happened?
Victor KimuraSEO, Web DeveloperAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Victor KimuraSEO, Web DeveloperAuthor Commented:
I figured it out. Thank the Lord. Was really stressful.

For some reason when I went to the Apache Configuration->Global configuration and changed the SSL Cipher I had to rebuild the Apache conf. But what WHM did was add this line on some (not all the FQDNs):

Include "/usr/local/apache/conf/userdata/std/2_2/myultrat/*.conf"

Creating a backup vhost.conf and appended /public/ directory as the Document Root to what was previously:
DocumentRoot /home/myultrat/public_html/testthis

In other words, that line became
DocumentRoot /home/myultrat/public_html/testthis/public

Strange. Or perhaps that was there before. Whatever the case, the WHM Apache added to some of the FQDN's this line:
Include "/usr/local/apache/conf/userdata/std/2_2/myultrat/*.conf"

So I change some of my vhost and created a default for the domains that were affected by adding the line:
Include "/usr/local/apache/conf/userdata/std/2_2/myultrat/myultratrust.com/*.conf"

So now I have this on some of the FQDNs:

<VirtualHost 173.201.47.54:80>
    ServerName myultratrust.com
    ServerAlias 47.201.173.in-addr.arpa www.47.201.173.in-addr.arpa www.myultratrust.com
    DocumentRoot /home/myultrat/public_html
    ServerAdmin webmaster@myultratrust.com
    UseCanonicalName Off
    CustomLog /usr/local/apache/domlogs/myultratrust.com combined
    CustomLog /usr/local/apache/domlogs/myultratrust.com-bytes_log "%{%s}t %I .\n%{%s}t %O ."
    ## User myultrat # Needed for Cpanel::ApacheConf
    UserDir enabled myultrat
    <IfModule mod_suphp.c>
        suPHP_UserGroup myultrat myultrat
    </IfModule>
    <IfModule !mod_disable_suexec.c>
        <IfModule !mod_ruid2.c>
            SuexecUserGroup myultrat myultrat
        </IfModule>
    </IfModule>
    <IfModule mod_ruid2.c>
        RMode config
        RUidGid myultrat myultrat
    </IfModule>
    <IfModule itk.c>
        # For more information on MPM ITK, please read:
        #   http://mpm-itk.sesse.net/
        AssignUserID myultrat myultrat
    </IfModule>
    ScriptAlias /cgi-bin/ /home/myultrat/public_html/cgi-bin/

    #Include "/usr/local/apache/conf/userdata/std/2_2/myultrat/*.conf"
    Include "/usr/local/apache/conf/userdata/std/2_2/myultrat/myultratrust.com/*.conf"

</VirtualHost>

Open in new window


I hope this helps someone out there.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Victor KimuraSEO, Web DeveloperAuthor Commented:
This is the answer. Figured it out by God's grace.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.