Server 2008 R2 Task Scheduler Will Not Fire

I set up a Scheduled Task on a Windows 7 desktop that opened Microsoft Access, then opened an Access database which had an AUTOEXEC to immediately run a report, save it as a .pdf, and then e-mailed this report to various people.  The task was set to then close the database and the e-mail program.  This was not ideal because the tasks were set to run on a computer in use and the environment had to be exactly right for the tasks to run (e-mail, Access closed, etc.).  It ran fine if everything was "perfect" but failed if it was not, so I decided to set the same task up on a server.  Unfortunately, I will not run.  It says it is running but nothing ever happens.

Actions:

Start a program.
Program/script:  "C:\Program Files (x86)\Microsoft Office\Office12\MSACCESS.EXE"
Add Arguments:  "F:\Public\- ACCESS Databases\E-Mail\Weekly E-Mail.accdb"

Can anyone shed some light on this?  I have tried a UNC path, changed the various options several times...   it just does nothing.

The last time I ran it (tried to run it), I had to end it and it failed with an (Ox7D4) error.

I am the IT Manager and have full administrative rights.

Thanks in advance!
ARH64Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

NVITCommented:
Is F:\Public a network share?
Make sure the task Runs As a user that has access rights to that share.
0
ARH64Author Commented:
Yes, it is a network share, housed on the server I am trying to run it from.  I have tried to go directly to the real drive as opposed to the network share with the same result.  I am running it as an administrator since it is on the server so it has access rights.  I've also tried to run it as "SYSTEM" and as myself (full admin rights) and still nothing.

I would try a batch file instead but am pretty rusty with writing them and am doubtful it would work, anyway.
0
NVITCommented:
As the same task user, have you tried running same program line and arguments manually? Does it work?
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

ARH64Author Commented:
Yes.  I was able to at least make it SAY it was running on a RUN NOW command....   now it does nothing at all.
0
NVITCommented:
No. I meant:
1. Open a CMD prompt
2. Paste the exact program and argument lines
3. ENTER to run it
0
ARH64Author Commented:
Ok.  So I ran the initial OPEN ACCESS with a CMD prompt and it initially had to start in Safe Mode (probably because I manually ended it so many times), which would explain why it never opened, I guess.

I fixed that, then tried to run the Access Database.  Outlook is telling me that a program is trying to send  an email on my behalf and is asking for an ALLOW or DENY.  This did not come up before but it obviously will not run on its own if it asks every time.  I will do some Googling about that unless someone knows how to fix it off the top of their head.  Will advise.
0
WiReDWolfCommented:
Open Outlook
- File
- Options
- Trust Center -> Trust Center Settings
- Programmatic Access -> Never Warn about suspicious activity (not recommended)

It should show "Antivirus status: valid" for this to work

Or you can add yet another Outlook Add-in that will let you 'whitelist' application access to Outlook
https://www.mapilab.com/outlook/security/

Personally I would write the batch file to set the stage and set the permissions /runas:administrator
- ensure the task is not already running
- ensure that Outlook is not running before starting the scheduled task
- ensure that Access is not running before starting the scheduled task
- write a quick log to confirm the job was done
0
ARH64Author Commented:
Wolf:  Have already tried the first option.  Changes to the Trust Center made no difference.

I am going to search a bit more before adding add-ons but will definitely try that as a last resort.

I have no idea how to write such a batch files.
0
NVITCommented:
An alternative is change how Access sends the email. Instead of thru Outlook, use a free command line alternative like BLAT
0
ARH64Author Commented:
I ended up uninstalling Outlook, installing Groupwise, and adding an address book.  Stumbled up it by trying different things...   can't tell you if that is exactly what I did and in that order but it seems to be firing now.

Thanks.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Seth SimmonsSr. Systems AdministratorCommented:
This question has been classified as abandoned and is closed as part of the Cleanup Program. See the recommendation for more details.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2008

From novice to tech pro — start learning today.