Need some super pro help for MailWasher Pro problem

I posted pretty much the same problem about a year ago when I bought MailWasher Pro. Here's that post, revised to update it:
------------------------------
...and it worked just fine on my Windows 7 Toshiba laptop. Then it started NOT working--not starting on bootup and NOT starting when I clicked on the desktop icon shortcut. After a few exchanges back and forth with support at  Firetrust, it started working again after minor tweaks and then stopped working....and then started working erratically...and then stopped. Clicking on the desktop icon did nothing.

Firetrust suggested I upgrade  the Microsoft .NET program from the computer. After doing so, MW Pro worked as it is supposed to,  but now I'm back to it not automatically starting on bootup.

I have uninstalled the program and made sure I installed he current version.

Some other info that may help a supertechie help me: I have ESET NOD32 installed (have used it for three+ years) and it starts automatically on bootup.  Never had a problem with it. Also, the dropbox icon appears in the toolbar, so I'm guessing it, too, starts on startup, And ditto for Ion Restorer. Although,  MailwasherPro DID work for a few weeks with all of these apparently also loading, and there were no conflicts.

Finally, and this may not be related at all, but I don't know, so I'm mentioning it here: ESET is due to renew in a few days, so I'm getting the reminder notice automatically appearing on bootup.

Does ANYONE have any suggestions on solving this hassle? I must admit I'm looking for replies from experts who have experience in this type of thing and not suggestions that anyone can find with a few Google searches.

Thanks.
RadioGeorgeOwner/ProgrammerAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chris Raisin(Retired Analyst/Programmer)Commented:
I am currently having the same problem with "Fences" and I think it might be related to Security.

I would suggest you look at this page and take the action suggested. I cannot guarantee it will solve the problem since I am trying it out on my own problem at the moment.

http://www.jimmah.com/vista/Administration/autostart_admin_program.aspx

When you run the utility (not manually) you should see your program listed showing the current
running suthority l;evel. Mine was listed in the "System" startup and not the "User" startup, and hence I did not have
authority to start the program. (Goodness knows how that happened).

After going through  the manual process, you should log off then log back on and see if the startup now works.
 
Let me know how you go.

Cheers
Chris

A program blocked in the startup processes
0
gheistCommented:
Microsoft recently fixed a loophole that allowed admin programs at startup (somebody demonstrated how to bypass elevation prompts in session using same system functions.

Complete answer is : "contact your vendor for updated version of software"
0
Chris Raisin(Retired Analyst/Programmer)Commented:
Ahhh...that may be the problem too....it seemed to start with Fences when Microsoft performed a recent update.
Still, I will try to get Fences going via the Unblocker (and the author of this question could try it out on Mailwasher).

Mind you, my wonderful Mailwasher is working fine on my machine, so the update probably has not affected him.
(See my mailwasher running in the screen capture above).

Cheers
Chris(Australia)
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

gheistCommented:
You can make a shortcut that runs it elevated (the consent prompt every time) to work around incompleteness in application..
0
Iain MacMillanIT Regional Manager - UKCommented:
i use MWPro as well, but i never have it running on start-up, only when i'm preparing to run Outlook and download my emails for the day.  You may well find it better to manually run the launch after your system has settled from its login.  It already prompts to ask for elevated permissions when it is launched.

Also try and disable ESET, i have had issues in previous years where the security settings of the app caused other issues with other software being allowed to run, for the last few years i have run Kaspersky AV.  Ensure you have the latest 4.5.2 .Net installed also.
0
RadioGeorgeOwner/ProgrammerAuthor Commented:
Thanks to one and all so far! Lots of ideas here that seem to make sense.

I am indeed running the latest 4.5.2.Net, since Firetrust suggested I do that.  Also, the desktop icon to the MWPro program simply does nothing. I will use the info provided here to date later when I can check into it without rushing and report back.
0
Chris Raisin(Retired Analyst/Programmer)Commented:
You can also go into properties of a shortcut you have created (and placed in the "Startup" folder for "All Users".
Give the shortcut "Administration" privileges. That should start it up each time a user logs on.
(If it is just for you, place it in the "User" staretup folder, noyt "all users".

To do this:
     1. Click on "Start"
     2. Click on "All Programs"
     3. Scroll down until you find "StartUp" (it is a folder)
     4. Right click on that folder then select either:
                     a  "Open" (if you are the only one to run the program on startup) or
                     b. "All Users" (if every user will be running the program on startup).
     5. Double-click on the item you have chosend under 4a or 4b
     6. Right mouse-button click to create a shortcut.
     7. Point to the program you want to run from your shortcut.
         (Don't forget to include any parameters in the Target link in the link, if needed (I don't think there are any for
         Mailwasher).
     8. Once the shortcut is created, right mouse-button click on it
     9. Select "Properties" and click on it.
   10. Select the "Shortcut" Tab
   11. Click on the "Advanced" button
   12. Tick the "Run as administrator" option.
THE FOLLOWING STEPS INVOLVING SECURITY ARE IMPORTANT
   13. Select the Security Tab
   14. Edit the permissions of each user, making sure that no permissions are inherited from any other source.
         (The word "Inherited" should not appear anywhere)
         For me, I usually make sure all users (including the System) have full access to everything
        - I just tick everything I can! LOL...Do that if you are the only user on your PC else set up as required for
          each user.
    15. If you need to adjust compatablility mode for your program (you won't with Mailwasher), click on the
          Compatability Tab and make necessary adjustments.
    16. By the way, make sure you have clicked "apply" whenever you make any changes
    17. Close the link dialogue box
    18. Windows Explorer
     19. Log off the system then log back in.

Hopefully your program should start up when you log on!


Cheers
Chris (Australia)
0
Chris Raisin(Retired Analyst/Programmer)Commented:
That last comment looked all well and good, and is worth a go, but it still has not worked on my "Fences" program, so I do not know if it will help you out with your program. It boils down now, I think, to a security problem with the program when it attempts to startup via the registry and must have something to do with the programs "kick in" which the Windows system no longer allows (thank to the recent Microsoft system changes).
Of course, that being said, MY Mailwasher was not affected by that change.
Of course I am using the OLD version of mailwasher (on purpose, because I prefer the old version to the new).

Try changing back to version 5.3 and I am sure you will find that it will run. The functionality is the same, just the
"desktop prettiness" may not be as good.

The only other approach is to contact Firetrust and get them to release a patch that works around the security restrictions now imposed on the program's startup.

Cheers
Chris (Australia)
0
Chris Raisin(Retired Analyst/Programmer)Commented:
I have made some progress using a scheduled event which I am just testing.
If it works, then I will pass the Info on so you can apply it to your Mailwasher situation.

Stand By....
Chris
0
RadioGeorgeOwner/ProgrammerAuthor Commented:
OK, the discussion continues....

I downloaded the jimmah .com utility Christopher suggested and see that Mailwasher is indeed on the list of programs started from the startup folder. Except it doesn't.

RE: "contact your vendor for updated version of software." What software? Mailwasher? I have the current version, which is less than a couple of months old. Still have the problem that inspired this posting.


gheist: I can't make a shortuct because I have absolutely no idea what you are saying. That's why I'm posting here on EE. I will not feel insulted if you or anyone responding explains this stuff to me as if I were a computer novice. The lingo does not make any sense at my level of understanding about this.

C. Rain's step-by-step list was a little confusing, moist likely because of small differences in his list and what appears in my computer (I have seen this more than I care to and I am sure it's because Microsoft does not keep current as teaks are made in versions of their OS's.

What I've done for the time being is to use Revo Uninstaller to completely uninstall everything and start over 100% from scratch. If, after another couple of days, the problem still exists, I'll once again try what's suggested here and if the fix just isn't there, I may try to revert to an earlier version.

Stay tuned....I guess....
0
Chris Raisin(Retired Analyst/Programmer)Commented:
You will find that the earlier version of MailWasher will work fine.

What you could try with the latest version is to set up MailWasher as a Scheduled Task to start up at user Logon (or system start-up) but make sure that you check the item "Run with Highest Priviliges" on the "General" Tab since that bypasses any UAC restrictions and ensures the scheduled event will run without any security problems.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
RadioGeorgeOwner/ProgrammerAuthor Commented:
Still a little uncertain about this but this seems to be the most logical answer.

I decided on an unusual gamble that seems to have solved the problem. I bought a copy of System Mechanic and ran the program to optimize the hard drive and also fix a surprisingly large number of technical errors which I classify as "unknown by a common, non-techie user. "

Now, MWP seems to be working OK and consistently.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Software

From novice to tech pro — start learning today.