How can i fix the problem rndc: 'freeze' failed: not found

Added new IP space to my master nameserver.  

Created the zone files, edited named.conf to add the /22, edited named.masterzones.conf to include the files.  

Did the same on both of my slave servers to accept the transfers properly.  (of course the masterzones.conf file is named slavezones.conf)  

Done this hundreds of times in the past.    

When i went to edit andy of the newly created zone files  I entered the following command:

rndc freeze <xxx.xxx.xxx.in-addr.arpa.

got the following message:

rndc: 'freeze' failed: not found

tried adding   "in" to the end...didn't work  

Oh.  BTW I also restarted named, ran named-checkconf and named-checkzone, rndc reconfig and rndc status.   All seems to be well.  

The zone files will not transfer to the slave servers.   Its like they are not even there.

HELP!!!
marchopkinsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zephyr ICTCloud ArchitectCommented:
You say you tried adding "in" to the end, like how?

Something like this: "rndc freeze abc.com IN internal"  or external
0
savoneCommented:
Try adding the -V option to rndc for verbose logging, it might give you a better idea of what is wrong.
0
Jan SpringerCommented:
and is that a typo or copy/paste?
0
What were the top attacks of Q1 2018?

The Threat Lab team analyzes data from WatchGuard’s Firebox Feed, internal and partner threat intelligence, and a research honeynet, to provide insightful analysis about the top threats on the Internet. Check out our Q1 2018 report for smart, practical security advice today!

marchopkinsAuthor Commented:
Running the command with the -V option:

create memory context
create socket manager
create task manager
create task
create logging context
setting log tag
creating log channel
enabling log channel
create parser
get key
decode base64 secret
freeze
post event
using server 127.0.0.1 (127.0.0.1#953)
create socket
bind socket
connect
create message
render message
schedule recv
send message
parse message
create message
render message
schedule recv
send message
parse message
rndc: 'freeze' failed: not found
0
marchopkinsAuthor Commented:
Tried:

rndc freeze xxx.xxx.xxx-in.addr.arpa.  in

and

rndc freeze xxx.xxx.xxx-in.addr.arpa. in internal

neither worked.
0
marchopkinsAuthor Commented:
???? Jan
0
Jan SpringerCommented:
that's exactly correct.  let me see if i can find anything else that might cause this.
0
Jan SpringerCommented:
are you calling your views "internal" and "external"?

have you tried the external view?
0
marchopkinsAuthor Commented:
i havent, simply because I've done this hundreds of times in the past with other zone files on the servers and it works on other files.  I just tested it again with others on the same master server, All good.
0
Jan SpringerCommented:
so, is it a problem with any zone on this server or just this zone on this server?
0
marchopkinsAuthor Commented:
Just the newly added block...  /22

As I said above, ive edited all the correct files   named.conf to add the block.   named.masterzones.conf to add the include files  mapped to /var/named/data  (slaves) on the slave servers.   Ran all of the proper checks.

Nothing.
0
Jan SpringerCommented:
and no errors from named-checkzone?

what do the log files say -- anything?
0
Jan SpringerCommented:
also, is this zone a master or a slave?

and, if master, does it work with the external zone?
0
marchopkinsAuthor Commented:
No, no errors at all.  logfiles say nothing.   I do see however that the new zones did not load, or transfer.

Master.   Its not sending to the Slaves....   tried external...failed:  not found.
0
Jan SpringerCommented:
so there's a problem with the zone.  what are the regular permissions?  

if running selinux, what are those permissions?

did you by verify the zone name in named.conf with the actual file name?
0
marchopkinsAuthor Commented:
LOL...well here's the funny thing.  

When doing a:

ls -rflst    in /var/named/data  (which is where my zone files are located)....The new files are     root:root   some of the old files are root:root    some of the files are named:named.  

all permissions are set to

-rw-r--r--.      

Which is actually correct?
0
Jan SpringerCommented:
chown root:named, chmod 640

You are not chrooted?
0
marchopkinsAuthor Commented:
Sorry don't know what chrooted means??
0
Jan SpringerCommented:
That your dns configuration is isolated from the rest of the system.  It's another layer of security.
0
marchopkinsAuthor Commented:
No... btw tried what  you suggested....didn't work
0
Jan SpringerCommented:
i think there is something wrong with the zone file itself.

is there any information when you run named-checkzone?
0
marchopkinsAuthor Commented:
Perhaps I am running it wrong.   can you give me the exact syntax??
0
Jan SpringerCommented:
named-checkzone ZONE /path/to/filename

i.e.,

named-checkzone 0.0.2.4.in-addr.arpa /var/named/data/4.2.0.0.rev
0
marchopkinsAuthor Commented:
Turns out that the path somehow got changed from

/var/named/data  

to

/var/named/chroot/var/named/data  for the new zone files.   No idea how that happened but i know what to look to for in the future.

Thanks Jan.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Jan SpringerCommented:
yes, /var/named/chroot/var/named/data is if you're chrooted.
0
marchopkinsAuthor Commented:
Her thoughts led to the solution.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.