Event ID 119 Windows 2008 R2 server

Windows 2008 R2 64 Bit

When ever I run gpupdate /force I receive this error

Log Name:      Application
Source:        WSRM
Date:          3/19/2015 12:30:38 PM
Event ID:      119
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      SERV010.FQDN.com
Description:
Windows System Resource Manager encountered the following error 0x80010117. User Name will not be logged in the subsequent event logs.

Error: 0x80010117

User Action
Address the error condition, and then try again.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="WSRM" Guid="{2c7f07f3-5d53-4e4e-b163-5a863f79aeb8}" EventSourceName="WSRM" />
    <EventID Qualifiers="32768">119</EventID>
    <Version>0</Version>
    <Level>3</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2015-03-19T16:30:38.000000000Z" />
    <EventRecordID>139322</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>Application</Channel>
    <Computer>SERV010.FQDN.com</Computer>
    <Security />
  </System>
  <EventData>
    <Data>0x80010117</Data>
  </EventData>
</Event>


I ran this

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

C:\Users\administrator>winmgmt /verifyrepository
WMI repository is consistent

C:\Users\administrator>winmgmt /salvagerepository
WMI repository is consistent


No change


Thoughts or suggestions

Thanks

Tom
LVL 23
Thomas GrassiSystems AdministratorAsked:
Who is Participating?
 
arnoldCommented:
When you forcibly update the GPO cache, it will be required for the process to rerun your WMI filters to determine whether this system/user falls under the filtering criteria.
I suspect when you instructing the system to update the GPO  (most systems will rerun and will advise the user needs to be logged out or for the computer GPOs the system needs to be restarted.)
Now in your case, the error is because when the GPOs are being refreshed, the filter might not be ........ accessible/triggerable and the error shows up. When the system boots up or when the user logs in, those filters are applied and that is the determinant whether the WMI filter is always causing an error (meaning typo in filter) or only when the gpupdate is ..

gpupdate /target:user /force

You would get the notice that to apply GPOs user needs to be logged off Y/N
See if you get an error from it.
Do you have a GPO set to manage wsrm?
Recheck the filters to make sure you do not get an error from one of them.
0
 
arnoldCommented:
If you do not see this error I. The normal operation of the system, I.e. Bootup or during user logins, I would. Not worry about it.
Gpupdate /force is likely triggering a refresh of policy/execution of your filters that leads to this error.
Do you have a GPO with Id {2c7f07f3-5d53-4e4e-b163-5a863f79aeb8}"
Try gpupdate refresh of the user GPOs to see if you get this error, if you do not, he GPO impacted is a computer GPO .......
0
 
Thomas GrassiSystems AdministratorAuthor Commented:
Arnold

Do you have a GPO with Id {2c7f07f3-5d53-4e4e-b163-5a863f79aeb8}"      No do not have this one.


Try gpupdate refresh of the user GPOs to see if you get this error, if you do not, he GPO impacted is a computer GPO .......

Can you explain this ?
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Thomas GrassiSystems AdministratorAuthor Commented:
Arnold

gpupdate /target:user /force    no error 119

gpupdate /target:computer /force   error 119

Where do I set GPO to manage WSRM?


The filters are all working putting more into production soon.
0
 
arnoldCommented:
If you do not an error 119 affecting wsrm during this system's bootup, IMHO, there is nothing to diagnose. To apply a GPO the user is forced to logout to reapply the updated GPO, the computer is required to be rebooted.

I understand why you ran gpupdate, but since it is not a common means of policy distribution, the error is incidental to the running of gpupdate.

I.e. When complaining to a DR that it hurts when I do this, the response is unless you have to do that, don't......
Short of trying to deny this computer access to each policy sequentially until you identify the GPO that causes the event.
0
 
Thomas GrassiSystems AdministratorAuthor Commented:
Arnold

I stopped WSRM on that server still get the same error when running gpudate

The same error over and over

The GPO 2c7f.... does not exist so why is it giving an error?

I will try to not run gpudate on that server for a few days lets see if we get the error
0
 
arnoldCommented:
2c was referenced in the error which I was trying to see whether it matched a GPO in which case it will help pointing to one.

Use gpmc to see what computer settings are set.
0
 
Thomas GrassiSystems AdministratorAuthor Commented:
Arnold

YEs that would be easy if it referenced something meaningful.

But what MS error is meaningful?

Don't understand how turning of WSRM and I still get WSRM errors?

I am looking at GPMC now the Group Policy Results for this server looks good.
0
 
arnoldCommented:
The error is not in the normal application of the GPO, it is only occurring with your last comment when you try to forcible reapply GPO settings onto the computer which require a reboot similar in a way to an forcible reapplication of User GPOs which forces the user to logoff to reapply.

The way to determine which GPO, you have to add within the GPO delegation a deny all to this server. then cycle through every Computer GPO that applies one at a time, denying only one GPO at a time.
1-3
1 Deny server
2 reverse deny of 1 and deny server
3 reverse deny of 2 and deny server

in between try the GPupdate /target:computer /force to see which GPO will give you this event,

But I still think this is a non-issue given the error is only displayed following a Gpupdate. During the normal application on boot or during the refresh of the GPO the error is not seen.
0
 
Thomas GrassiSystems AdministratorAuthor Commented:
Arnold

If I understand you here.

I have 11 GPO's
DC WSUS
Default Domain Policy
DNS Suffix
LOGONAsAService
Member Server WSUS
NTP Settings for Domain
Windows 7 WSUS
Windows 8 WSUS
Windows Vista WSUS
WSUS
WSUS Server Only

Take DC WSUS  GPO  add This Server  SERV010 to the Delegation goto advanced which gives you the security tab
Select the server SERV010 Deny full Control ?

Then run GPupdate /target:computer /force  on this server see if we get the error yes  change things back
Stop and report
No error
then do same process for DNS Suffix

I do not believe Default Domain Policy is the problem it has been around for a long time

Thought
0
 
arnoldCommented:
When task specific WSUS policies you can skip.  Default Domain policy, DNS Suffix, LOGONAsAService are the likely guesses.

leave Default domain and deny logonasaservice and DNS suffiX,  and see if GPupdate triggers the error.

https://social.technet.microsoft.com/Forums/windowsserver/en-US/78623acd-dc0e-4ebc-937a-e67e84b3f603/wsrm-event-id-119-401-800-every-two-minutes?forum=winservergen

I still believe this is a non-issue given it is not appearing when the system boots up normally.
I.e. if you could push your car in a perpendicular direction to its normal motion fast enough, the tires will screech,  trying  to eliminate tire screeching in this circumstance will not be necessary given it is contrary to the manner in which they operate normally.

My guess as the article above, I too have installed WSRM when it initially rolled out as a useful tool to manage resources, and there it is still installed without me configuring anything else given the need has not arisen that requires such at this time.
0
 
Thomas GrassiSystems AdministratorAuthor Commented:
Arnold,

After reviewing that article again I noticed one guy decided to uninstall WSRM

So that made me take a look at my other Windows 2008 server and guess what WSRM was not installed and gpupdate /force works no errors.

So I decided to uninstall WSRM from this Windows 2008 server also
I do not use WSRM at this point so a good test would be to remove it

It does require a restart so I need to schedule that tonight.

Will see what that does.

I would think if any of the GPO's had a problem my other computers would get a similar error

So far all other computers are getting successful GPO updates etc.

Will post results from the restart tonight

Thanks
0
 
arnoldCommented:
The error level is a warning it is not a consequential event in the scheme of things.
Warnings triggered after gpupdate /force should be expected given the common requirement during that process is to reboot the system for Computer GPOs and logoff the user for User GPOs.
0
 
Thomas GrassiSystems AdministratorAuthor Commented:
Update Server restarted today due to power outage
On the road will not be able to test until the weekend.

Removed WSRM  from system

Will see what happens
0
 
Thomas GrassiSystems AdministratorAuthor Commented:
Arnold

I was correct. Removing WSRM solved the problem

After power came back on tonight I was able to test the gpupdae /force from this server and no errors

WRSM had to be the problem must be a way to run both together. But since I do not use WSRM not going to worry about it at this time

Thanks again for all your help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.