MS Exchange 2010 ActiveSync Errors

been trying to get our exchange server 2010 to work with activesync to outlook 2013 clients
I have searched within experts exchange and all seem to point to sbs 2003
I ran the Microsoft activesync test and all passed but the following is what I get

Attempting the FolderSync command on the Exchange ActiveSync session.
  The test of the FolderSync command failed.
  Additional Details
Exchange ActiveSync returned an HTTP 500 response (Internal Server Error).
HTTP Response Headers:
Content-Length: 3653
Cache-Control: private
Content-Type: text/html; charset=utf-8
Date: Sun, 22 Mar 2015 17:19:12 GMT
Server: Microsoft-IIS/7.5
X-AspNet-Version: 2.0.50727
X-Powered-By: ASP.NET
Elapsed Time: 1593 ms.  
 
Can someone please help; i know it is somewhere in our server settings, also owa works fine
all help is greatly appreciated
d.elebute
David ElebuteSystems ConsultantAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Sarat chsystem adminCommented:
Hi David,

Is there any specific user complained about not receiving emails on their mobile devices.

In Exchange Server 2010, you may also experience this issue if the Exchange Servers group does not have the appropriate permission to the mailbox object in Active Directory. The most common cause for this is broken Access Control List (ACL) inheritance in Active Directory. Please find below KB

http://support.microsoft.com/default.aspx/kb/817379

http://www.egroup-us.com/2011/02/exchange-activesync-returned-an-http-500-response-exchange-2010/
0
David ElebuteSystems ConsultantAuthor Commented:
thank you srikanth chantati
do I need to restart server after the adding the setup from second link?
I still get the http 500 error after using second link suggestions
first link is windows 2003
funny thing just happened, when I select check mark on Ignore Trust for SSL; I get the http 500 error
if I remove the check mark I am getting a SSL error:
Validating certificate trust for Windows Mobile devices.
  Certificate trust validation failed.
  Test Steps
   The Microsoft Connectivity Analyzer is attempting to build certificate chains for certificate CN=server.serverdomain.com.
  A certificate chain couldn't be constructed for the certificate.
   Additional Details
  The certificate chain couldn't be built. You may be missing required intermediate certificates.
Elapsed Time: 33 ms.
 
 thanks again, I think I am getting closer
d.elebute
0
Cris HannaSr IT Support EngineerCommented:
Is this SBS 2011?
And I assume rather than Active Sync, you mean Outlook over HTTP?
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

David ElebuteSystems ConsultantAuthor Commented:
Yes it is sbs 2011 chris hanna
and i would like to get both working
owa works fine, but cannot get either active sync or over http
d.elebute
0
Cris HannaSr IT Support EngineerCommented:
I would suggest
a.  Run the SBS 2011 Best Practice Analyzer (make sure it's updated to 1.5)
b.  Run the remote connectivity analyzer https://testconnectivity.microsoft.com/
c.  Make sure you have the latest Service Packs for Windows Server and Exchange
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
David ElebuteSystems ConsultantAuthor Commented:
thanks again Cris Hanna
I have run the connectivity tests and only part that fails is the http 500 errors
all sp's in place on the exchange server
just tried again from outlook 2013 using just activesync I get a certificate prompt and then I get the error EAS server cannot be found
I stopped and restarted the IIS services and Exchange info store
d.elebute
0
David ElebuteSystems ConsultantAuthor Commented:
I am now getting the following error message from the ms active sync site

Testing HTTP Authentication Methods for URL https://remote.serverdomain.com/Microsoft-Server-ActiveSync/.
  The HTTP authentication test failed.
Additional Details
  Exception details:
Message: The underlying connection was closed: An unexpected error occurred on a receive.
Type: System.Net.WebException
Stack trace:
 at System.Net.HttpWebRequest.GetResponse()
 at Microsoft.Exchange.Tools.ExRca.Extensions.RcaHttpRequest.GetResponse()
Exception details:
Message: Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host.
Type: System.IO.IOException
Stack trace:
 at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
 at System.Net.FixedSizeReader.ReadPacket(Byte[] buffer, Int32 offset, Int32 count)
 at System.Net.Security._SslStream.StartFrameHeader(Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)
 at System.Net.Security._SslStream.StartReading(Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)
 at System.Net.Security._SslStream.ProcessRead(Byte[] buffer, Int32 offset, Int32 count, AsyncProtocolRequest asyncRequest)
 at System.Net.TlsStream.Read(Byte[] buffer, Int32 offset, Int32 size)
 at System.Net.PooledStream.Read(Byte[] buffer, Int32 offset, Int32 size)
 at System.Net.Connection.SyncRead(HttpWebRequest request, Boolean userRetrievedStream, Boolean probeRead)
Exception details:
Message: An existing connection was forcibly closed by the remote host
Type: System.Net.Sockets.SocketException
Stack trace:
 at System.Net.Sockets.Socket.Receive(Byte[] buffer, Int32 offset, Int32 size, SocketFlags socketFlags)
 at System.Net.Sockets.NetworkStream.Read(Byte[] buffer, Int32 offset, Int32 size)
Elapsed Time: 12034 ms.  

thanks again for help in helping us resolve this one
d.elebute
0
Cris HannaSr IT Support EngineerCommented:
You marked this as answered, but is it fixed or are you still having issues?
0
David ElebuteSystems ConsultantAuthor Commented:
it is fixed sorry...
0
Cris HannaSr IT Support EngineerCommented:
what wound up being the solution?  That's always helpful so that when someone else has a similar issue they might find the actual solution reviewing this question.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.