Cisco 881G with 4G backup not working

I can't get NAT working with 4G backup.

Basics:

F4 is working normally (NAT working)
4G connection is working normally, but inside cannot access outside when F4 is down

I can ping 8.8.8.8 thought 4G connection (when F4 is down)

Config might have few extra-lines cos i have run wizard and tried few combinations to get it to work.
And i snipped some config off

Router#show run
Building configuration...

Current configuration : 5195 bytes
!
! Last configuration change at 11:01:10 UTC Mon Mar 23 2015
!
version 15.5

!
!

!
ip dhcp excluded-address 10.10.12.1 10.10.12.99
ip dhcp excluded-address 10.10.12.200 10.10.12.254
!
ip dhcp pool insidepool
 import all
 network 10.10.12.0 255.255.255.0
 dns-server 8.8.8.8
 default-router 10.10.12.1
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
!
!
controller Cellular 0
 lte modem link-recovery rssi onset-threshold -110
 lte modem link-recovery monitor-timer 20
 lte modem link-recovery wait-timer 10
 lte modem link-recovery debounce-count 6
!
track 1 ip sla 1 reachability
!
!
!
!
!
!
!
!
!
!
!
!
interface Cellular0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation slip
 dialer in-band
 dialer pool-member 1
 async mode interactive
!
interface Cellular1
 no ip address
 encapsulation slip
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 ip address 188.127.x.x 255.255.255.248
 ip nat outside
 ip virtual-reassembly in
 duplex auto
 speed auto
!
interface Vlan1
 ip address 10.10.12.1 255.255.255.0
 ip nat inside
 ip nat enable
 ip virtual-reassembly in
!
interface Dialer0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation slip
 dialer pool 1
 dialer idle-timeout 0
 dialer string lte
 dialer persistent
!
ip local policy route-map track-primary-if
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list 1 interface FastEthernet4 overload
ip nat inside source list 23 interface Dialer0 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet4 188.127.x.x (WAN gateway)
ip route 0.0.0.0 0.0.0.0 Dialer0 253
!
ip sla 1
 icmp-echo x.x.x.x source-interface FastEthernet4
 frequency 5

route-map backup permit 1
 match ip address 23
 match interface Dialer0
!
route-map primary permit 1
 match ip address 23
 match interface FastEthernet4
!
access-list 1 remark CCP_ACL Category=2
access-list 1 permit 10.10.12.0 0.0.0.255
access-list 23 permit 10.10.12.0 0.0.0.255
access-list 100 remark CCP_ACL Category=0
access-list 100 permit icmp any host x.x.x.x
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
end

Router#

Open in new window

somicoyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kevinhsiehCommented:
I am curious, what hardware do you have for the 4G connection? I thought Cisco only supported 3G on the 881G routers.
0
Matt VCommented:
Your statements:

ip nat inside source list 1 interface FastEthernet4 overload
ip nat inside source list 23 interface Dialer0 overload

should be referencing route-maps to ensure that all traffic inbound on the NAT goes back out the same interface.

The configuration you have posted will take inbound traffic from the backup link and try to route the replies back out the default gateway for F4.

This is a good article for how to setup dual WAN connections:

https://supportforums.cisco.com/document/32186/dual-internet-links-nating-pbr-and-ip-sla
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
somicoyAuthor Commented:
on route-map what is next hop address with 4G ?

"set ip next-hop verify-availability"
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.