Application "hangs" after some time without work

Hi,

I have a POS application that works in vb.net and sql. If always make invoices is fast recording and printing. However after about 10 minutes stopped the application show the message "not responding" and takes a long time recording and printing. I have everything turned off in advanced energy options. How is it possible to avoid this problem.

best regards
rflorencioAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ste5anSenior DeveloperCommented:
Examine the cause of this problem?

Disable the data access layer of your application and check if it still happens.

When not, use SQL Profiler to see, whether it is cause to a lock on SQL Server.

btw, for a POS system you need to carfully design your database and the access strategy to avoid locks in the first place.
0
Vitor MontalvãoMSSQL Senior EngineerCommented:
How is it possible to avoid this problem.
The one million dollar question!
There's no direct answer for that. It's like if your car just suddenly stopped. And why it stopped? No more gasoline? Electrical problem? Are you breaking the car? The engine blew?

You need to check first, right?
You can start to check for errors in the machine and in the SQL Server. You can also start a SQL Profiler to capture the T-SQL statements to know where it stopped. You can start a SSMS session and check there for locking processes.
And these are only some tasks for start.
0
rflorencioAuthor Commented:
But the application is fast in continued operation, save and print less 2 seconds. The problem is when no one works in pos in intervals 10 minutes or longer.

best regards
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Vitor MontalvãoMSSQL Senior EngineerCommented:
The problem is when no one works in pos in intervals 10 minutes or longer.
Check if there's any antivirus running on the server. Usually they are configured to run when there's no activity.
Also check for SQL Server jobs running during the less performance periods.
0
ste5anSenior DeveloperCommented:
hmm, also check your database, not that you're working in auto-close mode.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rflorencioAuthor Commented:
Hi,

In fact is in autoclose mode. I changed to false and is more fast no doubt. Will any implications for example for a single POS to have this option to false.

best regards
0
ste5anSenior DeveloperCommented:
Well, how can we tell.. Is the database local to your POS?

Setting auto-close to false, means that your SQL Server instance while accquire and hold resources for your POS database, even when your primary POS application is not running.

So when it's on the local POS client, then this may add with other external factors to a resource shortage.
0
rflorencioAuthor Commented:
Hi,

Except some sporadic access to the Internet, usually the only application installed just only POS. And in this case no aditional machines "share" database.

best regards
0
ste5anSenior DeveloperCommented:
So, it should work. Just check how many memory you have granted to your SQL Server instance. I would limit this value.
0
rflorencioAuthor Commented:
Hi,

For a 2 Gb Machine which recommended value?

best regards
0
ste5anSenior DeveloperCommented:
How big is your database? But I would start with 1GB max.
0
ste5anSenior DeveloperCommented:
Please change the marked answer. It was clearly the  auto-close option.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server

From novice to tech pro — start learning today.