authorizing remote desktop

Hello,

So I'm trying to authorize remote desktop connection for our users in our domain. It seems what I did was unnecessary, since I was told someone made it work without touching the general policies.

I added the users that needed to do that to the group "remote desktop users" and I also added a GPO "Allow logon through Terminal Services" for the same users.

And now when I try to log on to a server with remote desktop connection it doesn't work anymore. But it works on workstation.

So I tried adding the rights to do remote desktop connections and I lost the rights to do it on servers. Is it the fact that I am on the remote desktop users group? would it be possible to be excluded from connecting to a server because of that?
vanroybelAsked:
Who is Participating?
 
Hypercat (Deb)Commented:
Ok - First of all, you CANNOT use your SBS2003 server as a terminal server.  The only remote desktop connections allowed for an SBS server are the 2 administrative connections.

You need to remove or disable the GPO you created if it is being applied to the server, and reboot the server.  Then go to the SBS2003 server and REMOVE any users that may still be listed due to the fact that the GPO was being applied to the server. You can do this by logging on locally to it, or by connecting via remote desktop to the admin console.  This is done by running the following command on the Run line on your workstation:

mstsc /v:[servername] /admin

When the logon box comes up, log on with the domain administrator user name and password. When you get connected to the server, then you can go into the system settings/Remote tab and REMOVE any users that you've added to the "Select Users" list.

Now, if you want to allow users to log on remotely to their workstations, you can do this through a GPO, but you have to create the GPO in a way that it is applied ONLY to the workstations and not to the server. You do not have to add the domain admin account to the "Allow logon through terminal services..." because it is by default allowed to log on either locally or remotely to any computer that is a member of the domain.
0
 
Matthew BorrussoCommented:
I am not sure what your looking to accomplish in the big picture.

If you have a group of servers or workstation acting as RDP hosts for clients to work off of, then you will need to make sure that each user has proper permissions to do so.

You could easily create a domain group that that belongs to the local remote desktop users group on the systems in question. This should allow the user the privilege to login locally to the box itself (most important on the server side).

Otherwise, the account settings only grants or denies the user the right to use remote desktop or not. You still need to have permissions on the local machine to allow remote access. On the workstation side, if you add the domain user, or the group like I mentioned to the local remote desktop users group, you should be fine as well.

If you want to do this on a grand scale automated, you may either need to script out some changes using net user or push via GPO. depends on your end result.
0
 
Matthew BorrussoCommented:
think of the setting in the user account like a clapper in front of a desk lamp.

The account setting is on or off like the clapper, but that does not mean the desk lamp is on.

The local systems access permissions is the desk lamp.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

 
Richard DanekeTrainerCommented:
If you are using the Small Business Server, there is a wizard in the setup to configure for remote access.  

Yes, it is to permit remote logon to the workstations.  In the User account properties, one can identify which workstation a user may connect to.  This way, remote users can connect to their individual workstations when working remotely.

The Administrator is permitted to logon to the server. Two concurrent remote connections are permitted.
0
 
Hypercat (Deb)Commented:
Are you trying to allow the users to connect to a terminal server, configured with user applications installed and terminal server licensing? In that case the configuration (adding the users to the remote desktop users group) has to be done on the terminal server, not the SBS server. You can do this in two ways:

1.  Add the users to the domain Remote Desktop Users group or some other custom group you create, and then add the domain group to the Local Users and Groups/Groups/Remote Desktop Users group on the terminal server (recommended method); or

2.  Add the individual domain user accounts to the terminal server Local Users and Groups/Groups/Remote Desktop Users group.
0
 
vanroybelAuthor Commented:
Hello,

First, what do I want to acomplish :
I was able to log in to my server (SBS 2003) using the domain administrator account. I cannot do that anymore. I want to be able to do it again. I think it should be able to do that by default, but it seems by defining the access this doesn't work anymore.


So I've been testing a bit this morning, and the server is not the problem, it is the administrator account (domain administrator). We usually always used the domain administrator to login to the server in remote desktop. I cannot login to the server with this account anymore, but my personal account works. Problem is I need administrator access on the server to make things work so I will still need to use the domain administrator account to work on it.

This account worked by default before. Maybe I have to add it explicitly somewhere (I added it to the list of users authorized to access the computer through remote access).

I you have any suggestions it would be welcome.

(I cannot find any wizard to configure remote access on SBS 2003)
0
 
vanroybelAuthor Commented:
So for now the administrator has been added to the GPO "allow log on through terminal services" and also on the computer properties, remote tab, I added the user.
I don't know what more to do so that the administrator has the rights to use remote desktop.

Can it sometimes take time to apply the GPO?
0
 
vanroybelAuthor Commented:
Oh and also I tried to log on the administrator with RDC and I cannot either, I still get the error "To log on to this computer, you must be granted the Allow log on through Terminal Services Right...".
0
 
vanroybelAuthor Commented:
I meant I tried to log on to a computer in the domain that is not the server with RDC and I got this message.
0
 
vanroybelAuthor Commented:
Thanks for the help, after removing users from both places I use remote desktop again with the administrator account.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.