ip / dns problem

I'm having a problem with my server 2008 R2 terminal server.  It looks like an IP / DNS underlying issue.  SERVER1 is my SBS Server DC and is running DNS, DHCP, etc.  SERVER2 is my term server and hosts about 30 users.  I noticed the issue when the latest version of my cloud backup software couldn't phone home and talk to it's cloud servers.  

I try running Remote Desktop Manager and get the following:
Exception Message: A non-recoverable error occurred during a database lookup
  at System.Net.Dns.GetAddrInfo(String name)
  at System.Net.Dns.InternalGetHostByName(String hostname, Boolean includeIPv6)
   .
   .
   .

I tried the following powershell command:
  [System.Net.Dns]::GetHostAddresses("www.msn.com")

and get this:
  Exception calling "GetHostAddresses" with "1" argument(s): "A non-recoverable error occurred during a
    database lookup"
At line:1 char:35
+ [System.Net.Dns]::GetHostAddresses <<<< ("www.msn.com")
    + CategoryInfo          : NotSpecified: (:) [], MethodInvocationException
    + FullyQualifiedErrorId : DotNetMethodException

nslookup gives these results:

C:\Users\administrator>nslookup
Default Server:  UnKnown
Address:  192.168.56.253

www.msn.com
Server:  UnKnown
Address:  192.168.56.253

*** UnKnown can't find www.msn.com: No response from server

> paumac02
Server:  UnKnown
Address:  192.168.56.253

*** UnKnown can't find paumac02: No response from server
>

So it seems there is an underlying dns issue.  However all users on this termserver can browse internet and resolve names via browser...

Any troubleshooting steps are appreciated.

Thanks, Jerry
apexnetworksAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tmoore1962Commented:
Is your SBS DNS configured for Forwarders or root hints?  try and configure for forwarders and if they're not avail then use root hints.  Verify your server's nic dns server ip addresses are correct - SBS server
apexnetworksAuthor Commented:
SBS (SERVER1)  is configured for forwarders.  DNS settings on SERVER2 are correct.  It's pointing to SBS server but according to nslookup, it is not getting a response from SERVER1.  Running the same nslookup commands on third server results in all correct responses.
vivigattCommented:
Have you tried ipconfig /flushdns on the Term Server?
Have you compared the result of ipconfig /all commands when run on a host which works OK and on the term server ?
apexnetworksAuthor Commented:
I finally ended up removing the following registry key (after exporting):

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network.

Rebooted and then rebuilt the nic information.  Fixed the problem.  
Don't really know what caused the issue....

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
apexnetworksAuthor Commented:
Fixed the problem.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
DNS

From novice to tech pro — start learning today.