sendmail not using mailertable relay

I've done this before and recently, but it's not working this time. I have the following in /etc/mail/mailtertable:

cantleysauto.com        novatec-inc.com

I did make mailertable.db and did restart sendmail. I then sent a message to a user at cantleysauto.com, but it delivered with the following in /var/log/maillog:
Mar 24 13:03:18 mail sendmail[3244]: t2OH3IHk003244: to=cantleys@cantleysauto.com, ctladdr=noreply@ohprs.org (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30313, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (t2OH3IvM003245 Message accepted for delivery)
Mar 24 13:03:19 mail sm-mta[3252]: t2OH3IvM003245: to=<cantleys@cantleysauto.com>, delay=00:00:01, xdelay=00:00:01, mailer=esmtp, pri=120470, relay=mail.cantleysauto.com. [108.66.178.143], dsn=2.0.0, stat=Sent (t2OH3IhV003613 Message accepted for delivery)

Open in new window

As you can see, it didn't even try to use the novatec-inc.com server and went right to mail.cantleysauto.com.

Why?
LVL 1
jmarkfoleyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
I think your syntax might be incorrect

http://www.sendmail.com/sm/open_source/docs/m4/mailertables.html

first, I would check whether the feature to translate is enabled.
Then the entry might need to be
domain SMTP:mailserver

not clear what you are looking to do, are you looking to route email sent to domain1.com through domain2.com's mailserver?

I believe the use of mailertable will only try to send emails destined to the domain in the pattern through the mailertable route, if it is unreachable, I do not believe it will fall through and attempt to send to MX.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kenfcampCommented:
Try using this:
cantleysauto.com      smtp:novatec-inc.com

Ken
0
jmarkfoleyAuthor Commented:
Putting SMTP: in front of the target server did the trick, although I successfully did this with a different target server a week ago without the SMTP: prefix. Not sure why it worked then. Maybe something to do with the target server. Dunno. Anyway, that solved my problem.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Email Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.